Unable to configure Google Analytics Plugin for Confluence

I tried to install evaluation version of this plugin but I am getting the following error.

The following error(s) occurred:•Problem with the Google Analytics service getAccountsList

How can this be resolved?

6 answers

1 accepted

3 votes
David Simpson Community Champion Apr 22, 2013

@Srinivas Patruni The latest version of Google Analytics for Confluence has a much simplified configuration screen. Please try it out, the "generate Google API key" step has been removed. It's much easier.

It's not the library that's the issue, but the API key from the Google API console that was used.

David Simpson Community Champion Jan 13, 2013

In the Google APIs Console, we need to configure "Simple API Access"using a "Key for browser apps", then use this key to access the data. Doing this fixes the problem.

I've tried this with our site but it doesn't seem to resolve the error.

David Simpson Community Champion Apr 22, 2013

This answer is now incorrect as of version 2.2.0 of the plugin. Unfortunately, I can't seem to delete my answer :(

Hello Spatruni,

Some preliminary research indicates that this might be a problem with the library that the google analytics plugin may be using an outdated library to interact with the Analytics API. This is a third party product and the best I can do is offer a bit of speculation. I would try installing the latest version of the plugin that is compatible with your system and trying once again.

If that does not work for you, I think it might be a good idea to ge ahold of Appfusions directly. I am including their support page from our marketplace below.

https://marketplace.atlassian.com/plugins/me.davidsimpson.confluence.plugins.googleanalytics/version/2110/support

Hi Daniel,

I tried couple of times installing this plugin on our confluence 4.1.6 but it is showing the same error. so I mailed the same to the support id info@appfusions.com.

Thanks, Srinivas

David Simpson Community Champion Jan 13, 2013

@Daniel It's not the library that's the issue, but the API key from the Google API console that was used.

Hi David, I am running with the same issue again. Though i tried with different browser key types, i am still facing this issue. Please advise on how to proceed further.

Contact us at info@appfusions.com for support -

Answers is not AppFusions support channel - impossible to provide proper support here since no direct notifications on issues that affect us always, and so timeliness is a best effort at best - and at the rate that Answers questions move, we can't track every question instantly.

Please try to understand.

info@appfusions.com

A new release for this plugin was just released, so simplify the configuration a little.

Hope it helps.

Contact info@appfusions.com to get a license and try it.

A new release for this plugin was just released, to simplify the configuration a little.

Hope it helps.

Contact info@appfusions.com to get a license and try it.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published 11 hours ago in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

35 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you