Unable to Log TIme in Tempo v7.4

We have recently upgraded our test jira with Tempo v7.4 and tried to log time for users but get a permissions error - Unable to log time against issue...

Is there a known problem?

3 answers

1 accepted

This widget could not be displayed.

Hi guys,

We have fixed the problem. Version 7.4.0.1 is available on the Marketplace.

Sorry for the inconvenience,

-Bjarni

Yeah, all sorted.

Thanks for the rapid fix and release.

That's fixed it for us. Thanks very *very* much for the quick resposne :-)

This widget could not be displayed.

Hi Matthew.

We haven't heard about this issue. You should be able to check why you cannot log work for the user by filling in the Worklog validation form in Tempo Administration.

http://wiki.tempoplugin.com/display/TEMPO/Worklog+Date+Validation

Please enter the date, username of the user you want to log work, and your own username, and finally the issue-key.

Please let us know if this doesn't help you to clear this up.

Hello,

We're experiencing the same issue. This only started happening after updating to the new version of Tempo today - no permissions have changed. I can also note that through the worklog date validation page, everything is passing fine.

As a developer, I've debugged the following notes:
* when entering time in the worked field, a request is submitted to /rest/tempo-rest/1.0/worklogs/remainingEstimate/calculate/ which is 404'ing, and this causes an alert('error') popup to display
* following is the request and response when clicking the Add button on the Log Work dialog (some detail omitted for security and brevity)

POST /rest/tempo-rest/1.0/worklogs/*snip*-214 HTTP/1.1
Host: jira.*snip*
Referer: http://jira.*snip*/secure/TempoUserBoard!timesheet.jspa
Content-Length: 175

billedTime=1&comment=test&date=31/Oct/12&enddate=31/Oct/12&id=&issue=*snip*-214&planning=false&remainingEstimate=&startTimeEnabled=false&time=1&tracker=false&type=&user=

HTTP/1.1 200 OK
*snip*
X-AUSERNAME: nick.silvestro
Content-Length: 233

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><submit-result valid="false"><errors><formFieldId>issue</formFieldId><errorMessage>You do not have permission to add worklog on this issue</errorMessage></errors></submit-result>

Let me know if you need any other detail, or if there's a better place to send this info to.

Cheers,
Nick

Hi Nick and thanks for the info,

You are getting: "You do not have permission to add worklog on this issue" error.

Are you logging time for yourself or sombody else? Do you get the error on all issues or just some?

-Bjarni (Tempo support)

Thanks for the reply Bjarni.

Users are logging time for themselves, this is happening across all issues, and is affecting all our users with both standard and administrative privileges.

This widget could not be displayed.

This is the same for us too..

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Jul 25, 2018 in Marketplace Apps

Jira Cloud and Bitbucket Cloud Integration with Microsoft Teams

One of the newest products in the Microsoft family - Microsoft Teams,  is a chat-based hub for teamwork that integrates all the people, content, and tools your team needs to be more engaged and ...

733 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you