Tasks crossed off

Why are all my scheduled tasks crossed out / have a strikethrough even though they are not resolved?

2 answers

1 accepted

This widget could not be displayed.

Finally found one screen that I removed Resolution from and it worked!

This widget could not be displayed.

You might be using resolution incorrectly. Have you got a custom workflow? Can you check the actual *resolution* field on the issues that are struck out (not the status!)

I remember seeing this before somewhere. When you create a sub-task, the Resolution field gets set to the default 'Unresolved'. Where in the workflow would I change that?

We saw that 'Unresolved' was set to the default in Issues Attributes/Resolution and 'Cleared' defaults. But when I created a sub-task the resolution was still set to 'Unresolved'. Is there a way to prevent this from happening? Resolution also appears required but when looking at Default Field Configuration it is not required.

Ah, be careful here - "unresolved" is a display, NOT the value. It actually means "the field is empty".

If you've added "unresolved" as a resolution, then that would explain this - the strike-out is based on "field is not empty", so if you've got a resolution of "unresolved" instead of "null which displays unresolved", you'll be breaking the functionality. Could you check that before we go further? Go to admin -> Resolutions and make sure there really is no "unresolved" on the list?

Unresolved is on the list. I don't remember adding it. Should I delete it?

Definitely!

And have a word with the other admins to make sure they don't put it back! They've accidentally set up a nonsensical situation where issues appearing as "unresolved" are resolved, simply because there is something there!

However, you need to check your workflows to make sure it's not being set by any post-functions in them. Also, if you have a lot of issues that are resolved-but-unresolved, then you might want to do this when the system is quiet - it needs to edit and re-index every issue that has the incorrect setting.

OK, getting closer. I removed the resolution 'Unresolved'. I created a new task and it applied the system 'Unresolved'. In ActivityTimeline, it was not crossed off. I then went to edit the task so that I could add an estimate. I was unable to save the page because resolution is required, technically it said: http://screencast.com/t/fkdFMQWdFjHo.

How do I make the resolution not required or keep it NULL?

Getting there :-)

Go back into the project header and look for the "field configuration scheme". Go into that and look at each field config (often, there's only one, but not always). Go into each of them and find the field "resolution". You'll find that resolution is set to mandatory, which you can click on to revert to optional.

How is Jira telling you that it's mandatory on screen?

I do not have any field configuration 'schemes' but I do see the Default Field Configuration. When I view the Resolution field, it is not set to be 'required'. http://screencast.com/t/iwa3fNLamd and http://screencast.com/t/lcIlBuJWxK5.

Thanks so much for your continued help with this!

When I edit a task, eg. to add an estimate, I'm unable to save the page because resolution is required, technically it said:http://screencast.com/t/fkdFMQWdFjHo.

Yup, that one worked :-)

Could you try removing the resolution field from that screen?

I just recently had this same thing happen to me (due to 3 different jira admins).

After you remove "Unresolved" from the list, go to Field Configurations > Resolution > Screens, uncheck Default Screen.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 22, 2018 in Marketplace Apps

How a Marketplace app tech team is achieving gender diversity

Hello! My name is Genevieve Blanch, and I'm the Marketing Manager at RefinedWiki, creators of apps to give teams the tools to customize Atlassian platforms. Currently, 44% of the tech team at Re...

504 views 3 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you