TIMEOUT on Bitbucket Webhooks with PLESK Onyx

I always get a timeout after ~5 seconds in Bitbucket Webhooks with a PLESK Onyx URL. It does not matter whether it's HTTP or HTTPS. Also disabling SSL Cert check did not have any impact. 

When I start the request from PLESK (manually PULL) it does work. So the connection does work in general.

The SSH Public Key is added in Bitbucket and correct. Same for the URL Bitbucket should trigger. 

Any Ideas why there's a timeout when Bitbucket wants to initiate the action?  

1 answer

 

I have the same issue since ~2 weeks. 

My Server is receiving the request and is pulling the repo, but the response ends with a "timeout", so after a few tries, bitbucket will deactivate the webhook, so the git no longer gets updates automaticly.

 

My Question to this: Is this a new Bug, which is produced with the last update?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published 2 hours ago in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

15 views 0 1
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you