SumUp Not working when it comes to Secure Fields

I've installed the Secure Fields plugin (which is basically just the same custom fields, but allows me to have more indepth security and permissions on them).

I copied the values (using Script Runner) from my original custom field into my new custom field, and changed the SumUp config to use the new custom field, but now it's not working.

Please see screenshots for reference...

sumup_ss_01.png

 

sumup_ss_02.png

 

sumup_ss_03.png

1 answer

0 vote

The secure fields are not the same as ordinary "custom fields".  They announce themselves as "secure number field", not "number field".  SumUp can only work with "number fields" - even though a secure number field may return a number when queried, SumUp has no way of knowing that is going to happen.

You need to talk to the authors of both plugins - either secure fields need to present their number fields as number fields, or SumUp needs to recognise and handle secure number fields.  (I suspect the latter is the correct way to go on a technical level)

Thanks Nic, I will try to put in a patch/update request to see if this can be done!

Where do I go to put in a feature request for this plugin?

https://marketplace.atlassian.com/plugins/com.atlassian.cps.sumUp - there's an issue tracker link under the support tab

Nic, it keeps asking me for an Atlassian Support Cloud login, which I don't have. The subdomain (cp-systems.atlassian.net) doesn't look like something I have access to get into. Is there a particular login I should be using, or should I go through the normal Create Ticket with JIRA workflow?

I've not asked for support for SumUp stuff, so I'm afraid I don't know the derails. I think you want to go through "Create issue" in there, but I don't know about accounts.

Without an account to whatever cp-systems.atlassian.com is, I can't create a ticket. I'll just try and go through the normal Create Issue chains via JIRA.

cp-systems.atlassian.com is the issue tracker for SumUp. You'll need to create an account and raise the issue there. I don't know what you mean by "Create issue chains via JIRA", there's loads of JIRA installs out there, but you need to be using the SumUp one, or it won't get to the SumUp team.

Nic, apparently this is the place to ask questions and/or get support for SumUp...the Issue Tracker is not open to the public. Do you have a POC or anyone with SumUp that could be reached? I've tried asking the question in the "Reviews" section for SumUp, but no response there either...any ideas?

I'm afraid that if a 3rd party vendor won't let you raise issues in their tracker and doesn't respond to your efforts to contact them in other ways, you're going to be a bit stuck. Using Answers for help is a good start - there's people here who may be able to help, and I've tried to help because I've run into much the same problem, and always feel it's worth sharing (my client only had it as a very low priority - "nice to have" and already had workarounds for their pattern of use, so we didn't chase it) But we can't support it in any formal way :-( We're not the vendor, don't have the code and most of us don't have the expertise either (I'm not a developer for example, I can only get so far with code) One of my colleagues did work with SumUp and ran into problems with that project and I think we ended up with another workaround involving the script runner, so I'll ask him if he ever got any contact with the vendor But I'm afraid you might be stuck. We really need SumUp to talk about this.

Nic, I appreciate your help, I really do. I think I might need to look into another solution as well. I like this tool, but as you said before, there seems to be little to no support from the vendor to get anything worked. I may reach out to you soon once I look into the Script Runner capabilities a little more...thanks again for all your help!

Hey there, I'm very sorry about the very late response. Christmas and illness is not a good combination.... Thank you a lot for the hint with the broken link to our issue tracker! The correct adress (I have updated it a few moments ago on the marketplace page) is decadis.atlassian.net. It is an open instance, so everyone can read the tickets. If you want to comment or create an issue, you are able to sign up and create an own account. I have created an ticket for you there (https://decadis.atlassian.net/browse/SUM-21) As I wrote just in the review, yesterday we started with the scripted field support sprint. I think your problem could be the same as we have with scripted fields and I will speak with my team, if we could resolve it within the current or the next sprint. Maybe you are interested in testing the beta? Cheers Julian

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Marketplace Apps

Three tips for boosting your board's efficiency with Story Maps

Trello is one of the most effective tools for driving your sprints. It's customizable for every Agile team and product owners and Scrum masters (SM) love it. However, Agile teams often struggle with:...

863 views 2 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you