Story Map crashes after install

I've just installed the trial version of Agile Story Map. When I click the Story Map link it crashes with a system error. I'm running JIRA Enterprise: Hosted.

I get the following cause:

javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated

Then a stack trace.

2 answers

1 accepted

Hi Wolfie,

yes this exception occurs due to an SSL certificate: https://answers.atlassian.com/questions/122754/story-map-plugin-exception-peer-not-authenticated

Until now I was not aware that plug ins are available at the on demand environment - or is it a dedicated environment, hosted by Atlassian?

This week we will release version 2 of story map, where this issue is solved!

cheers,

Florian

sorry for my late reply - it seems that the email notification did not work :(

Thanks Florian. Do I need to uninstall and reinstall version 2? And will the trial period restart, because I've wasted over a week trying to resolve this issue.

No, an update should be enough. If your trial period expires, just apply for a new 30 day period and you will get it, of course.

Hi Florian. I just updated to v2 and it still crashes. Also the Story Map link on the bar near the top of the screen reads StoryMap.label

Hi Wolfie, I see. it is a new build (2.0.1) provided. please update.

but is it still the same exception or a NullPointerException?

Hi Florian, it's a null pointer exception. I can send you the stack trace if you need it.

ok, this what we solved with 2.0.1, isn't it? thx for this info Wolfie!

Didn't solve it for me. I still get the null pointer error

hm ok, could you please provide the stack trace? do you use GreenHopper? which version?

Can't fit it in here. Can I email it to you?

0 vote

It's trying to connect to something that's ssl protected (https probably). It has not been given the right certificates to connect to it. I think this is down to how you've configured it - what are you using it to connect to?

Thanks for the feedback Nic. I'm running a hosted version of Jira, so all the configuration I've done so far was to install the trial version of the plugin. Other than that I've done nothing.

So you have not tried to connect it to anything else yet?

What do you mean by "hosted"? If you're not running it on your own servers, you might need to get in touch with the people who are hosting for you.

It's hosted by Atlassian. So I have nothing to do with the server configuration. I've had no help from them. They've referred me to the people who wrote the plugin and so far I've heard nothing from them, so I think I'll remove it and write it off as a waste of time.

Sorry to hear that, but I think you've made the right choice. Atlassian's stuff is broadly correct in it's setup and all the problems I've seen getting OnDemand to talk to other systems have been on the other systems end of it. Without support from the plugin authors, I agree that you're probably stuck :-(

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Marketplace Apps

Three tips for boosting your board's efficiency with Story Maps

Trello is one of the most effective tools for driving your sprints. It's customizable for every Agile team and product owners and Scrum masters (SM) love it. However, Agile teams often struggle with:...

824 views 2 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you