Set custom field in 'Clones an issue and links' post function doesnt work for select list

Hi,

I am trying to clone a log and set up a custom field (single select drop down list).

I went to Post Functions -->Script Post-Function -->Clones an issue and links.

 

Cloning works fine but as soon as I add 'Set custom field' in 'Additional issue actions' my whole post function stops working.

I am using pre-populated script below

def cf = customFieldManager.getCustomFieldObjects(issue).find {it.name == 'MyCustomFieldType'}
issue.setCustomFieldValue(cf, 'my value')

 

where 'MyCustomField Type' = 'Type' and 'my value' = 'Bug Fix'

so it looks like this

def cf = customFieldManager.getCustomFieldObjects(issue).find {it.name == 'Type'}
issue.setCustomFieldValue(cf, 'Bug Fix')

 

From what I understand this is not working because 'Set custom field' works only for string values, not select lists (drop down lists).

Can anyone help me write script for a select list???

Thanks

 

0 answers

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Thursday in Marketplace Apps

You + one app + a desert island...

Hi all! My name is Miles and I work on the Marketplace team. We’re looking for better ways to recommend and suggest apps that are truly crowd favorites, so of course we wanted to poll the Community. ...

144 views 3 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you