Service Desk Script Post Function Email not sending on transition

When a ticket is being transitioned in service desk from one queue to another, we have transitions created in a custom workflow that is supposed to trigger a script post function, that should send a custom email. No matter what we do it never triggers. The ticket moves queues... but like now the Script Post Function will always say "never run". I've talked to two consulting firms that couldn't give me an answer on why it wasn't working... SHOULD the post function fire for service desk queue moves like it does elsewhere? Could you provide some help?

Thanks,

Tim

2 answers

This widget could not be displayed.

What happens when you do this from JIRA rather than service desk, does the post function fire?

If it doesn't then there may be an issue with how you have configured the email post function. Can you try changing it to a simple one, just put "Hello" as text for the body and templates and see if that works.

Do you see any messages in the logs?

This widget could not be displayed.

Also worth turning debug logging on to see whats happening when you do the transition: https://scriptrunner.adaptavist.com/latest/jira/getting-help.html#_support_requests

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 22, 2018 in Marketplace Apps

How a Marketplace app tech team is achieving gender diversity

Hello! My name is Genevieve Blanch, and I'm the Marketing Manager at RefinedWiki, creators of apps to give teams the tools to customize Atlassian platforms. Currently, 44% of the tech team at Re...

524 views 3 19
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you