Send a custom email - Error

I performed several tests on appeal "Send a custom email" in "Script Runner Builtin" it works for viewing and sending email. But when I insert the script in "Post-Function" in Transition "Create Issue" it does not send e-mail and returns no error.

Here are the codes used

Condition: ['Blocker']. Contains (issue.priority '. Name)

Email template: The $ $ issue.issueType.name issue.key was created with priority <% Out << issue.priority '. Name%>. <br>

Summary: $ {} issue.summary <br>

Responsible: $ {issue.assignee '. Name}

Subject template: The Bug Blocker: $ issue was created | DISCLAIMER |

Email format: HTML

To addresses: e-mail address

What could be wrong?

1 answer

0 vote

Either answers is screwing your formatting or your code is wrong... can you paste a screenshot?

Or try the same code in the admin panel -> send email function, this will show you what the email will look like and evaluate the condition and stuff.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published yesterday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

42 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you