Send a custom email - Error

I performed several tests on appeal "Send a custom email" in "Script Runner Builtin" it works for viewing and sending email. But when I insert the script in "Post-Function" in Transition "Create Issue" it does not send e-mail and returns no error.

Here are the codes used

Condition: ['Blocker']. Contains (issue.priority '. Name)

Email template: The $ $ issue.issueType.name issue.key was created with priority <% Out << issue.priority '. Name%>. <br>

Summary: $ {} issue.summary <br>

Responsible: $ {issue.assignee '. Name}

Subject template: The Bug Blocker: $ issue was created | DISCLAIMER |

Email format: HTML

To addresses: e-mail address

What could be wrong?

1 answer

0 vote

Either answers is screwing your formatting or your code is wrong... can you paste a screenshot?

Or try the same code in the admin panel -> send email function, this will show you what the email will look like and evaluate the condition and stuff.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Marketplace Apps

Three tips for boosting your board's efficiency with Story Maps

Trello is one of the most effective tools for driving your sprints. It's customizable for every Agile team and product owners and Scrum masters (SM) love it. However, Agile teams often struggle with:...

818 views 2 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you