ScriptRunner "Copy custom field values" and Radio Buttons

Hi Atlassian,

I'm able to Copy custom field values of a Radio button to a Select List (single choice) for under 100 tickets in under a minute of time. Both custom fields have only "Yes" and "No" options. However, when I increase the number of tickets to 300 or greater, the "Copy custom field values" just keeps running, it never appears to finish.

I don't see Radio button mentioned within list of conversions handled. see https://scriptrunner.adaptavist.com/latest/jira/builtin-scripts.html.

Do you know if I can copy a Radio button to a Select List (single choice)?

Thank you!

David 

 

 

 

2 answers

This widget could not be displayed.

Hi David,

I have tested the copy custom field values built in script in my JIRA 7.1.0 instance and can confirm that the built in script will allow values to be copied from a radio button field to a select list field.

Please note the values must exist in both fields in order for the option selected to be copied and any missing options can be added using the Bulk Import Custom Field Values built in Script.

The script should work for more than 300 values. If you are still experiencing issues can you please provide us with the details below so that we can look to help further.

1.) Details of your version of JIRA and ScriptRunner.

2.) Confirmation that the options from the Radio Button field exist for the Select List field.

3.) A copy of the atlassian-jira.log file from when the script is executed.

I hope this helps.

Thanks

Kristian

This widget could not be displayed.

Hi Kristian,

Unfortunately it still doesn't work when I run with 300 issues. Note that, eventually I need to run this on over 6000 issues. 

Jira version 6.4.7 with Scriptrunner 3.0.16

Confirmed Values "Yes" and "No" exist in both fields. 


Added question, when we run bulk edits we limit the number of issues to 1000, should do the same for ScriptRunner? 

 

Thanks!

 

 

 

David 



Hi David,

I cant see anything at the end of the log's indicating where the error occurred the last time the function was ran.

Can I please ask you try upgrading to the latest version of ScriptRunner for JIRA 6.4.7 which is version 4.1.3.10 which can be downloaded on the marketplace here to test if the issue is resolved in a newer version. You can use a trial licence to install this.

Many Thanks

Kristian Walker

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 22, 2018 in Marketplace Apps

How a Marketplace app tech team is achieving gender diversity

Hello! My name is Genevieve Blanch, and I'm the Marketing Manager at RefinedWiki, creators of apps to give teams the tools to customize Atlassian platforms. Currently, 44% of the tech team at Re...

513 views 3 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you