ScriptRunner: linkedIssuesOfRemote does not work with "?" in the URL

Hi,

I am trying to query my Issues for specific Confluence Links. So I linked a Issue to a Confluence Page with the URL (for example) http://my.server.com/confluence/pages/viewpage.action?pageId=2097319 and used a query like issuefunction in linkedIssuesOfRemote("http://my.server.com/confluence/pages/viewpage.action?pageId=2097319") but I get no results (even after manually starting the indexing process). I tried some stuff and it looks to me, that when specific characters are used inside the URL (for example "?" or "&") it is not possible to query them any more...

I am using JIRA 6.4.7 with ScriptRunner 3.1.4 and also tested 3.0.11. Does anyone have a similar problem and maybe found a solution?

TIA

1 answer

Hi Klemens,

This sounds like an issue that we need to take care of.

Would you mind creating a ticket in https://jamieechlin.atlassian.net/secure/Dashboard.jspa?

Thanks,

Alejo

Any updates? I'm having the same issue.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 11, 2018 in Marketplace Apps

You + one app + a desert island...

Hi all! My name is Miles and I work on the Marketplace team. We’re looking for better ways to recommend and suggest apps that are truly crowd favorites, so of course we wanted to poll the Community. ...

3,642 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you