Script verification

Can anyone tell me why the ''create subtask'' built in script won't trigger with this ''aditional action'' script: 

 

 

issue.summary = issue.getSummary() + ' :Benchmark Offer' 
def cf_1 = customFieldManager.getCustomFieldObjectByName('Sponsor')
val_1 = '|*Sponsor*|' + issue.getCustomFieldValue(cf_1) 
def cf_2 = customFieldManager.getCustomFieldObjectByName('Admin Panel')
val_2 = '|*Admin Panel*|' + issue.getCustomFieldValue(cf_2) 
def cf_3 = customFieldManager.getCustomFieldObjectByName('Product')
val_3 = '|*Product*|' + issue.getCustomFieldValue(cf_3) 
def cf_4 = customFieldManager.getCustomFieldObjectByName('Category')
val_4 = '|*Category*|' + issue.getCustomFieldValue(cf_4) 
def cf_5 = customFieldManager.getCustomFieldObjectByName('Niches')
val_5 = '|*Niches*|' + issue.getCustomFieldValue(cf_5) 
def cf_6 = customFieldManager.getCustomFieldObjectByName('Program Id')
val_6 = '|*Program Id*|' + issue.getCustomFieldValue(cf_6) 
def cf_7 = customFieldManager.getCustomFieldObjectByName('Tour Id')
val_7 = '|*Tour Id*|' + issue.getCustomFieldValue(cf_7) 
def cf_8 = customFieldManager.getCustomFieldObjectByName('Country')
val_8 = '|*Allowed Countries*|' + issue.getCustomFieldValue(cf_8) 
def cf_9 = customFieldManager.getCustomFieldObjectByName('Payin Type')
val_9 = '|*Payin Type*|' + issue.getCustomFieldValue(cf_9) 
def cf_10 = customFieldManager.getCustomFieldObjectByName('Payin Rate')
val_10 = '|*Payin Rate*|' + issue.getCustomFieldValue(cf_10) 
val_11 = '|*Offer*|' + issue.getSummary() 
val_ls = System.getProperty("line.separator")
issue.setDescription(val_1 + val_ls + val_2  + val_ls + val_3 + val_ls + val_4 + val_ls + val_5 + val_ls + val_6 + val_ls + val_7 + val_ls + val_8 + val_ls + val_9 + val_ls + val_10 + val_ls + val_11)

Thank you and have a good one !

Phil

4 answers

0 vote

What do the logs say?

Error! No such property: issue for class: Script83 groovy.lang.MissingPropertyException: No such property: issue for class: Script83 at Script83.run(Script83.groovy:1)

0 vote

can you post a screenshot of the configuration pls

In that screenshot you are missing the "i" from issue, on line 1, but that doesn't tally with the error you reported

Yup, fixed the ''i'' still no creation. Please help me Jamie Kenoby , you are my holy hope !

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Marketplace Apps

Three tips for boosting your board's efficiency with Story Maps

Trello is one of the most effective tools for driving your sprints. It's customizable for every Agile team and product owners and Scrum masters (SM) love it. However, Agile teams often struggle with:...

829 views 2 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you