Script Runner inSprint function does not return any values

Hi,


I've installed the latest version of the Script Runner plug-in, but i'm unable to use the inSprint function.
Use case:
I click on the 'View in Issue Navigator' link in the Plan mode from a certain Rapid Board, but if i have a planned (or started) sprint with a number of issues, a different number of issues (or none) are returned.

For example;
In planned sprint 'quark' i have 8 issues.
If i press the 'View in Issue Navigator' button, i get 'no issues were found to match your search'.
(issueFunction in inSprint("Product Backlog - Team Zilver", "quark"))

in 'quark 2' i have 13 issues, but in the issue navigator 29 issues are returned.

I've read the 'there are a couple of caveats' on this page: https://jamieechlin.atlassian.net/wiki/display/GRV/Scripted+JQL+Functions

but it seems that my problem is something different.
Any ideas?

Script runner version: version 2.1 beta-8
Jira version:5.2.7
Greenhopper version:6.1.4

12 answers

This widget could not be displayed.

I need to revisit this... I've rewritten this code to use a different implementation... will release soon.

This widget could not be displayed.

Thanks for your reply Jamie.

I'll wait a while then with introducing the new Script runner here :)

This widget could not be displayed.

After about three rewrites I've hit on some new way, please can you try the latest: https://marketplace.atlassian.com/plugins/com.onresolve.jira.groovy.groovyrunner/version/978

This widget could not be displayed.

Hi Jamie,

First, thanks for your efforts.
Second, i've installed BETA9 of your plug-in.

Figured, lets start with a clean slate:
Stopped jira,removed the /caches/ directory, and all the other plugins.
Started Jira, reinstalled Greenhopper, reinstalled Script Runner, started a full reindex.

After the reindex, i tried opening an existing board and existing upcoming sprint:
Warning: The JSON input text should neither be null nor empty.

Tried removing the upcoming sprint, and creating a new one 'xxx'.
Warning: The JSON input text should neither be null nor empty.

Any ideas?


This widget could not be displayed.

Edwin, can you see if any of the three restrictions apply to you: https://jamieechlin.atlassian.net/wiki/display/GRV/Scripted+JQL+Functions#ScriptedJQLFunctions-inSprint(boardname,sprintname)

As I say, it's difficult to justify spending much time on this, as I can't believe it will be long before a similar function is in GH.

This widget could not be displayed.

Hi Jamie,

No, none of the restrictions apply to me. (logged in with a local user,
I understand you don't want to put much effort in it anymore.
Just checked the logging, and i see one ERROR:

2013-03-18 12:52:46,676 http-bio-8080-exec-11 ERROR admin 772x2913x1 7auc9z 10.60.24.36 /rest/issueNav/1/issueTable/ [jira.groovy.jql.AbstractScriptedJqlFunction] Failed to execute http://xxxx.xx.xxx.xxxxx.nl:8080/rest/greenhopper/1.0/rapidviews/list?query=Product Backlog - XXX - status code: 505

This widget could not be displayed.

That's interesting... I will look into that. Are you running jira in it's native tomcat, ie just vanilla, or do you have some other container, or apache / nginx in front of jira?

This widget could not be displayed.

Ah sorry, it's a really stupid encoding bug... will fix very soon.

This widget could not be displayed.

If you want to test it you could temporarily rename the board to not have spaces in it, or try with another board. Will release a new version tonight anyway.

This widget could not be displayed.

Can you try the latest version please... (thanks for your patience).

This widget could not be displayed.

Jamie; sorry for my late response, i tried your latest version, and that seems to work correctly for new upcoming sprints; already existing upcoming sprints seemed to work 50-50.

This is workable for us though.

This widget could not be displayed.

Jamie; i just installed it in our production instance, but the only thing i get is 'Connection refused'.
I've checked if the remote api is on, and i tried executing the action with a remote and local user.

Any other suggestions?

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published 4 hours ago in Marketplace Apps

The 7 hacks of highly successful automation

...there's anything I've learnt from working, it's that people are lazy! No offense to anyone reading this, but it's true and we can all admit it. The easier you make something for someone, the more...

26 views 0 7
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you