Script Runner custom email will not run

I just got Script Runner installed and configured the example as outlined in

https://jamieechlin.atlassian.net/wiki/display/GRV/Built-In+Scripts#Built-InScripts-Sendacustomemail

The Preview comes back with out error

But when I press 'Run' I get, " Result no return value" and no email is sent

I know the Jira email is working, I've made changes to the ticket and emails were sent as expected.

Thanks

Grant

2 answers

0 vote

You have to add it as a workflow post-function. It's just in admin -> scripts for ease of previewing the result. At the time I had no method to do a preview in the workflow function.

Thanks

My first thought was that I could invoke a test using the run button. I did create a workflow transition function, which worked perfectly.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Jul 10, 2018 in Marketplace Apps

If you’re an Atlassian app developer, you’ll want to know about Atlas Camp!

This September 6-7, hundreds of Atlassian App developers will flock to Barcelona Spain to build skills, discover product roadmaps, meet face-to-face with the Atlassian team, and learn how to extend t...

178 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you