Scheduler Pro can not edit existing "Job"

Craig Hylwa March 6, 2013

When attempting to edit existing "Job" the following error is generated.

Cause:
java.lang.IllegalStateException: Cannot retrieve 'resolution' as the issue has not been saved yet.

3 answers

1 accepted

0 votes
Answer accepted
Craig Hylwa March 10, 2013

I have removed the Resolution Field from the Create Issue Screen and I now no longer receive the error

Craig Hylwa March 13, 2013

There is no need for this feature from our part. This was configured in this way by mistake.

Thank you for the follow-up

0 votes
Łukasz Kreczmer
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 10, 2013

Hello Craig,

I am just trying to reproduce this error and seems that the problem raised becouse the Resolution field is placed on Create Issue Screen. I'am going to analyze this problem in depth tomorrow morning.

I will let you know if the issue will be resolved.

Regards,

Lucas Kreczmer

Łukasz Kreczmer
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 13, 2013

I should also ask is there any business need for you to place Resolution field on Create Issue Screen? We didn't considered such a case before, but it doesn't mean that such case shouldn't be implemented - if of course there is any business need behind.

Best Regards,

Lucas Kreczmer

0 votes
Leszek Zborowski March 7, 2013

Hello Craig,

Could you please provide us full stack trace from atlassian logs file?

If you prefer you can send it to atlassian@tt.com.pl email.

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events