SQL for confluence datasource only available to administrators

I have installed sql for confluence express and set up a datasource, but only confluence-administrators can see the datasource in the macro drop down. When I log in as a non-admin there aren't any selections.

I didn't have Macro Security installed, but I tried installing that with the options below, and still no luck. 

sql = *ANY
sql.datasource.* = *ANY
sql.datasource.DB3 = *ANY
sql-query = *ANY
sql-query.datasource.* = *ANY
sql-query.datasource.DB3 = *ANY

 

I'm using confluence 5.7,  org.swift.confluence.sqlexpress version 7.1.0

1 answer

1 accepted

0 votes
Accepted answer

Thanks for reporting this. We will track this as SQL-356. This is now resolved in 7.1.1 released today.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in Marketplace Apps

How to set up an incident workflow from the VP of Engineering at Sentry

Hey Atlassian community, I help lead engineering at Sentry, an open-source error-tracking and monitoring tool that integrates with Jira. We started using Jira Software Cloud internally last year, a...

1,137 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you