SQL exception thrown by the Active Objects library - Only dates between January 1, 1753 and December 31, 9999 are accepted

Tried looking at a users timesheet after selecting a date range search for view.

Date range was current year and approx 1 month back from today.

Then select the action button (next to username in timesheet list)

3 answers

1 accepted

Hi Matthew,

I am confident that we have fixed this ugly database error. This should be part of Tempo 7.5.2 that will be released tomorrow(ish).

There is still a minor bug that when you go to a user's timesheet from the Project timesheet (with the date pickers visible) you won't necessarily land on the same dates. I have created an internal issue on that, to be solved soon.

Thank you so much for reporting this and helping us to debug the issue! If you have any further bugs to report, you can use our public JIRA: https://tempoplugin.jira.com/

Hi Matthew,

Can you reproduce this?

Could you please send us the url that causes this error, and your JIRA logs would be much appreciated (it is sufficient to get the last few hours worth of logs).

Cheers,

Benedikt

Tempo Team

Yes easy to replicate.

Cannot send full log but extract is below.

URL:https://xxxxxxx/secure/TempoProjectBoard!timesheet.jspa?v=1&periodType=FLEX&periodView=DATES&from=01/Mar/13&to=31/Mar/13

Log detail:

04-Mar-2013 08:50:58 org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet [action] in context with path [] threw exception [com.atlassian.activeobjects.internal.ActiveObjectsSqlException: There was a SQL exception thrown by the Active Objects library:
Database:
- name:Microsoft SQL Server
- version:10.00.2723
- minor version:0
- major version:10
Driver:
- name:jTDS Type 4 JDBC Driver for MS SQL Server and Sybase
- version:1.2.4

java.sql.SQLException: Only dates between January 1, 1753 and December 31, 9999 are accepted.] with root cause
java.sql.SQLException: Only dates between January 1, 1753 and December 31, 9999 are accepted.

Hi Matthew,

Let me investigate and get back to you, later today or tomorrow.

Could you just let me know what version of Tempo you are using and we will get right on it.

v7.4.3 of Tempo

Hi Matthew,

I've been looking into this, and I've been able to reproduce a similar error. I am not sure though that it covers your case, as I am unable to reproduce this error with your string.

So to recap: You're viewing a timesheet where you have manually entered some dates (in this case 01/Mar/13 to 31/Mar/13 - and the timesheet appears alright? But when you select the "gear" next to somebody's name you get an error? This happens right away? Some screenshots could be beneficial.

Can you also let us know what language you have set, and what the jira.date.picker format you are using on your server? This information is available in JIRA System Info.

Thanks for helping us out!

Error occurs on selecting 'View Timesheet' from the action dropdown list.

Language is: English (UK)

and user picker details is: dd/MMM/yy h:mm a

Hi Matthew,

Thanks for your quick response. Can you send me the link url from the action dropdown list, should be something like :

https://xxx/secure/TempoUserBoard!timesheet.jspa?userId=zzz&period=....

https://xxxxx/secure/TempoUserBoard!timesheet.jspa?userId=xxxxx&period=01022013&returnUrl=https%3A%2F%2Fxxxxxx%2Fsecure%2FTempoProjectBoard!timesheet.jspa%3Fv%3D1%26periodType%3DFLEX%26periodView%3DDATES%26from%3D01%2FFeb%2F13%26to%3D28%2FFeb%2F13%26selectedIssueId%3Dxxxxxx&atl_token=BQKN-P72M-5YTP-JZS3|764315c89be02556a982f8839858bce5fdd602af|lin

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

74 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you