Recurring issue does not send email when created.

I have setup a few recurring issues to:

1) Create the issue on a defined schedule and put it in my issues list.

2) Send an email when the issue is created.

My log tells me the issue was created (and it was), and it tells me:  "Successfully sent email for issues:"

What am I missing in my setup, or how can I best troubleshoot why the email does not seem to sending?

1 answer

0 votes
Andreas Knecht Community Champion May 21, 2017

Hi Kyle,

Most likely your problem is that your send e-mail action needs to be on a 'related issues' branch for the created issues.

Here's an example:

created-branch.png

The problem is that generally the main branch of an Automation rule refers to the issue that triggered the rule (if you're using an 'issue updated' trigger for example).  To refer to issues created by the rule, you need to use the 'Related issues' action.

Hope this makes sense!

Cheers,
  Andreas

Worked perfect.  Thank you so much!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in Marketplace Apps

How to set up an incident workflow from the VP of Engineering at Sentry

Hey Atlassian community, I help lead engineering at Sentry, an open-source error-tracking and monitoring tool that integrates with Jira. We started using Jira Software Cloud internally last year, a...

1,333 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you