Re-installing old version

Hello!

We are using JIRA 6.4, and recently upgraded our version of ScriptRunner not realizing it would break functionality. 

 

What is the best way to install our old, working version of ScriptRunner? We were using version 3.1.4.

 

Thanks! 

1 answer

1 accepted

You can uninstall, then download 3.1.4 or your choice from https://marketplace.atlassian.com/plugins/com.onresolve.jira.groovy.groovyrunner/versions, then install that via the UPM -> Upload plugin option.

Would be interested to know what was broken though.

Hi Jamie, thanks for the quick response! That ended up working, by the way. I should rephrase and mention that nothing was broken per say, but we updated the plugin not realizing it was for JIRA 7.0, which we are not on yet. So the downgrade was needed to restore functionality until we upgrade to 7.0 in a couple months, in which we'll also upgrade to the appropriate version of Scriptrunner. Does that help?

Yes, thank you. But we maintain two forks at the moment that have the same functionality, one for jira 7, and one for jira 6.3+. 4.1.3.7 is the latest for jira 6, and 4.2.0.4 is the latest for jira 7. If you install through your app it should offer you the correct version. Both are paid-for though.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 31, 2018 in Marketplace Apps

Marketplace Spotlight: Zephyr

Hello Atlassian Community! Each month, we run a series of Spotlights to highlight Marketplace vendors and apps that our team thinks this Community would find valuable. In last month's Spotlig...

412 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you