Problems with workflow diagram plugin in Jira.

I have just created a new workflow and which when I upload it to a project is not showing the diagram. The error I have got from the logs is this

658x356807x1 prsoq7 10.87.77.136 /plugins/servlet/com.onresolve.WorkflowDiagramServlet [jira.web.action.WorkflowDiagramServlet] Graphviz error:
(dot.exe:6352): Pango-WARNING **: couldn't load font "Helvetica Oblique Not-Rotated 12", falling back to "Sans Oblique Not-Rotated 12", expect ugly output.

It works on other workflows ok?

4 answers

1 accepted

I think that's probably not the right error from the logs - I get that message logged every time the workflow is viewed and it doesn't stop the workflow displaying so there's probably another entry in the logs for the error that's causing the workflow not to display.

See JVIZ-23 for more info on the Pango-Warning - the plugin site is probably a better place to seek help / raise issues for this plugin rather than a general JIRA Q&A site. Check out other logged issues in case yours is a known problem - I had problems displaying workflows that had ampersands in their name so the first thing you could try is renaming your workflow to remove any potentially problematic characters such as ampersands and plus signs.

1 vote

J Thomas is on the money... that warning is just a warning.

The ampersands bug is still outstanding... simple enough fix IIRC, just not got round to it yet.

Also it's a lie, the output is not that ugly! If you find it ugly you can always use SVG or PDF.

Removing the "&" and replacing it with "and" resolved my problem. Thank you

Hint: you get points for accepting helpful answers :)

BTW that problem (JVIZ-52) has been fixed in the latest and final release, 1.5.5.

Yep with 1.5.5 and Graphvix 2.28 it seems to be resolved for me (I was still having the issue with Graphvix 2.26.3)

I think there are two issues - firstly the pango warning which is harmless, but solved by the later graphviz, and second the missing images caused by ampersands etc in workflow names, which is solved by jviz 1.5.5.

I've tried Graphviz 2.28.0 and the errors "seem" to have disappeared, maybe worth a try

0 vote

BTW that problem (JVIZ-52) has been fixed in the latest and final release, 1.5.5.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Marketplace Apps

Three tips for boosting your board's efficiency with Story Maps

Trello is one of the most effective tools for driving your sprints. It's customizable for every Agile team and product owners and Scrum masters (SM) love it. However, Agile teams often struggle with:...

849 views 2 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you