Outlook Plugin does not connect

Hello we are running JIRA Service Desk in Eval Mode, we tried diffrent types of outlook Plugins but they were not able to connect to JIRA service desk

our Version: (v6.4.7

as connection settings we tried to use the same url, that we use for the webinterface:

http://192.168.71.14:8080   that did not work

then we tried to change the base url into jira.kaikaito.de  and modified our hosts to point to 192.168.71.14
the webinterfaces works fine with http://jira.kaikaito.de:8080  but the Outlook Plugin won't connect.

in EVAL we're allowed to have ONE Agent - we typed the username and Password of that agent but not succes.

any ideas? do we have to activate any API  .

 we also tried to activate the rest-api  under systemsettings but no succes.

 

we appreciate any help - thanks in advance.

 


3 answers

The URL (IP and FQDN) including the port looks fine so far.

Do you use  the lastest version (currently v.1.6.0) of our Addon (http://plugins.extern.catworkx.de/display/O2J/Downloads)? What error message you do you get when you try to test the connection? It should at least tell you that the connection timed out, the REST endpoint could not be found or if you use invalid credentials.

To check if the REST-API is working properly just check the output of  http://192.168.71.14:8080/rest/api/2/user?username=admin (change the username to a valid user).

 

In case you get the error message: "Invalid URI: The format of the URI could not be dertermined" in v.1.6.0

We figured out what's the issue here. In some cases, depending on in which order you configured the connection settings, an empty URL as JIRA-URL will be saved. After reopening the connection settings it will ignore whatever you put in as JIRA-URL when testing the connection. It will use the empty URL saved before and you will always get the error message above.

However, all you need to do is to enter the JIRA-URL and just click "Save" without testing the connection. When you reopen the connection settings and you test the connection it should work.

The error message "The format of the URI could not be determined" only appears in case the URL is empty.

We will fix this behavior soon.

We released v1.6.1 today, which will fix this issue.

https://plugins.extern.catworkx.de/display/O2J/Downloads

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Tuesday in Marketplace Apps

If you’re an Atlassian app developer, you’ll want to know about Atlas Camp!

This September 6-7, hundreds of Atlassian App developers will flock to Barcelona Spain to build skills, discover product roadmaps, meet face-to-face with the Atlassian team, and learn how to extend t...

113 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you