Not able to install the plugin

Hello, I'm trying to install the latest version of the plugin (4.0.4) and I always get the same error in my Jira 6.0.7: NoClassdefFound javax.servlet.http.HttpServletRequest. Previously I had the 3.2.1 version. I have tried to upload it, delete index directory, delete database tables, but nothing works. Please, any idea? This is a production system.

Thank you, David.

3 answers

1 accepted

The library is present in the instance in the Tomcat/lib directory, but I had to explicitly include into the classpath.

We'll try to upgrade to 4.0.4 in a test environment.

Regards.

Maybe re-installing the 3.2.1 might make it available in production again.

If you have not a copy of that version, email me and I'll send you the binaries.

I've been able to install the 3.2.1 version, but I had to add servlet-api.jar to the classpath explicitly.

Regards.

What version did you install? The 3.2.1 or the 4.0.4? If it was the 3.2.1 version and it runs by adding the the servlet-api to the classpath , then the 4.0.4 would also run because it was affected by the same problem.

This is really strange issue because the servlet-api is part of the Tomcat distribution and it should be visible by all the classes running on it. Well, JIRA uses a sort of sandbox (Felix) to isolate the add-ons, but the servlet API is always exposed by default to all the add-ons... it is really amazing that such library is not present in your JIRA instance.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

78 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you