NoClassDefFoundError with Xcode build task

I've never been abe to get the Xcode plugin working. Builds always fail with:

jvm 1 | 2013-05-16 14:04:03,439 ERROR [7-BAM::Default Agent::Agent:pool-19-thread-1] [PrefixDelegatingModuleFactory] Detected an error (NoClassDefFoundError) instantiating the module for plugin 'com.atlassian.bamboo.plugins.xcode.bamboo-xcode-plugin' for module 'xcodeTaskType': com/atlassian/bamboo/task/CommonTaskContext. This error is usually caused by your plugin using a imported component class that itself relies on other packages in the product. You can probably fix this by adding the missing class's package to your <Import-Package> instructions; for more details on how to fix this, see http://confluence.atlassian.com/x/QRS-Cg .

jvm 1 | 2013-05-16 14:04:03,439 FATAL [7-BAM::Default Agent::Agent:pool-19-thread-1] [ExecuteBuildTask] Failed to execute the build 'TPROJ-TPLAN-JOB1-5'

jvm 1 | java.lang.NoClassDefFoundError: com/atlassian/bamboo/task/CommonTaskContext

jvm 1 |at java.lang.Class.getDeclaredConstructors0(Native Method)

jvm 1 |at java.lang.Class.privateGetDeclaredConstructors(Class.java:2398)

jvm 1 |at java.lang.Class.getConstructors(Class.java:1461)

jvm 1 |at org.springframework.beans.factory.support.AbstractBeanDefinition.getResolvedAutowireMode(AbstractBeanDefinition.java:520)

jvm 1 |at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBeanInstance(AbstractAutowireCapableBeanFactory.java:832)

jvm 1 |at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:440)

jvm 1 |at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory$1.run(AbstractAutowireCapableBeanFactory.java:409)

jvm 1 |at java.security.AccessController.doPrivileged(Native Method)

jvm 1 |at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:380)

jvm 1 |at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:300)

jvm 1 |at sun.reflect.GeneratedMethodAccessor79.invoke(Unknown Source)

jvm 1 |at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

jvm 1 |at java.lang.reflect.Method.invoke(Method.java:597)

jvm 1 |at com.atlassian.plugin.osgi.spring.DefaultSpringContainerAccessor.createBean(DefaultSpringContainerAccessor.java:109)

jvm 1 |at com.atlassian.plugin.module.ClassPrefixModuleFactory.createModule(ClassPrefixModuleFactory.java:32)

jvm 1 |at com.atlassian.plugin.module.PrefixDelegatingModuleFactory.createModule(PrefixDelegatingModuleFactory.java:99)

jvm 1 |at com.atlassian.bamboo.plugin.descriptor.AbstractBambooModuleDescriptor.createModule(AbstractBambooModuleDescriptor.java:26)

jvm 1 |at com.atlassian.bamboo.plugin.descriptor.AbstractBambooModuleDescriptor.getModule(AbstractBambooModuleDescriptor.java:90)

jvm 1 |at com.atlassian.bamboo.task.TaskExecutorImpl.executeTasks(TaskExecutorImpl.java:183)

jvm 1 |at com.atlassian.bamboo.task.TaskExecutorImpl.execute(TaskExecutorImpl.java:94)

jvm 1 |at com.atlassian.bamboo.build.pipeline.tasks.ExecuteBuildTask.call(ExecuteBuildTask.java:87)

jvm 1 |at com.atlassian.bamboo.v2.build.agent.DefaultBuildAgent.build(DefaultBuildAgent.java:206)

jvm 1 |at com.atlassian.bamboo.v2.build.agent.BuildAgentControllerImpl.waitAndPerformBuild(BuildAgentControllerImpl.java:103)

jvm 1 |at com.atlassian.bamboo.v2.build.agent.DefaultBuildAgent$1.run(DefaultBuildAgent.java:111)

jvm 1 |at com.atlassian.bamboo.build.pipeline.concurrent.NamedThreadFactory$2.run(NamedThreadFactory.java:52)

jvm 1 |at java.lang.Thread.run(Thread.java:680)

jvm 1 | Caused by: java.lang.ClassNotFoundException: com.atlassian.bamboo.task.CommonTaskContext

jvm 1 |at java.net.URLClassLoader$1.run(URLClassLoader.java:202)

jvm 1 |at java.security.AccessController.doPrivileged(Native Method)

jvm 1 |at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

jvm 1 |at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

jvm 1 |at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

jvm 1 |at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

jvm 1 |at org.eclipse.jetty.webapp.WebAppClassLoader.loadClass(WebAppClassLoader.java:424)

jvm 1 |at org.eclipse.jetty.webapp.WebAppClassLoader.loadClass(WebAppClassLoader.java:377)

jvm 1 |at org.apache.felix.framework.ExtensionManager$ExtensionManagerModule.getClassByDelegation(ExtensionManager.java:672)

jvm 1 |at org.apache.felix.framework.resolver.WireImpl.getClass(WireImpl.java:99)

jvm 1 |at org.apache.felix.framework.ModuleImpl.searchImports(ModuleImpl.java:1345)

jvm 1 |at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:711)

jvm 1 |at org.apache.felix.framework.ModuleImpl.access$200(ModuleImpl.java:73)

jvm 1 |at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1690)

jvm 1 |at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

jvm 1 |... 26 more

jvm 1 | 2013-05-16 14:04:03,452 INFO [7-BAM::Default Agent::Agent:pool-19-thread-1] [DefaultErrorHandler] Recording an error: Failed to execute the build 'TPROJ-TPLAN-JOB1-5' : TPROJ-TPLAN-JOB1 : com/atlassian/bamboo/task/CommonTaskContext

3 answers

1 accepted

In the end I fixed it by using the 5.0beta of Bamboo. It seems the current plugin only really works with that.

Getting the same error - any luck?

Hi Jobin,

could you please give a small hint how to downgrade the plugin, thanks.

You'll need to uninstall the plugin and download v1.8 from the plugin site.

Thanks Darren. This worked for me.

0 vote

Downgrade the XCode plugin to v1.8 and try again. That fixed the issue for me.

That worked for me. Thanks.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published yesterday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

62 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you