My timesheet not showing any results

ictime is not showing any timesheet results for any user within the system irrespective of how that work was logged, i.e. via a task or via the log work button in the timesheet view (see attached)

Is there a configuration setting that may alter this?

5 answers

Have you just started using the plugin? Maybe you should try re-indexing. Often solves those kind of problems...

Yes, i have just started to use the plugin - I'm evaluating it to see if it fits our requirements.

I have re-indexed - no resolution. I have re-installed - no resolution.

ictime by default shows results for the current week in the timesheet. If your work log dates match this and nothing is displayed, this should be a bug. In fact there is a known issue/bug with the timesheet we are currently working on, this might also explain your problem.

Do you maybe use Postgres as database?

Best regards

Tobias

the worklog dates match the current week, and I have extended the timesheet search parameters to the whole month to make sure the worklog can be reported on but get a "no results" result.

I have used the standard local install of Jira - can you advise how to check if it is a Postgres database?

There might have occured an error that is only visible in the atlassian-jira.log file, resulting in the "no results" display that you experienced. If you could send us your jira logs from that specific timeframe where you tried to see anything on the "my timesheet" page, we should definately be able to solve that problem.

Best regards

Tim

Thanks everyone for your help so far.

The extract from the log file is attached. Let me know if you need any other information. (atlassian-jira_log_ictime_entries.txt)

Thank you for the log file. As far as I can see there are only minor warnings and an exception that was raised on the ictime configure page, but other than that nothing seems to go wrong when accessing the "my timesheet". Could you do a simple report with the ictime-report functionality to clarify if the problem only exists on my timesheet.

After doing a report, take a look at the log file and look for any SQL-Exceptions or Errors that might indicate a problem if you dont see any time entries. If you do see the time entries after doing a report, we have to take a closer look at "my timesheet".

Just to make it clear, you have logged at least one time entry on an issue without any problems, so there should definately be something to see?

Yes, I have logged time on several issues, at least one issue is still open.

I have attached screenshots and the new log file extract, again, let me know if you need more info.

(atlassian-jira_log_ictime_entries_reporting_test.txt)

These are the issues that have already had worklogs recorded for them.

This is the open timesheet with work logged against it.

Thats quite interesting, because the report clearly shows the time entries which should be seen in your "my timesheet" as well. So they are definately there, now its time to find out why they are not shown in the timesheet. Maybe you can send me another screenshot of the "my timesheet" page with the "no results" display, just to make sure everythings fine there.

So far, my guess is either a wrong configuration or a sql exception, though the latter would be strange since I havent seen any exceptions in your logs.

ictime Configuration screenshot:

here's the latest log extract: (atlassian-jira_log_ictime_entries_post_reporting_test.txt)

My timesheets screenshot:

We have been using ictime for a while now. When we updated to the latest version earlier this week, the "My Timesheet" function suddenly started failing. Users cannot get their individual time reports, but if they select "All Users" for the same report, it works.

Can someone please help with this?

We are currently testing ictime and experienced the same problem.

My guess is that my timesheets in empty because the work of the user that creates the work log is not really connected to it. The user's work is not shown in My Work Log tab and also not summed up at My Time.

Could you tell us why the work log I create is not associated to me as a user?

We have been using ictime for a while now. When we updated to the latest version earlier this week, the "My Timesheet" function suddenly started failing. Users cannot get their individual time reports, but if they select "All Users" for the same report, it works.

Can someone please help with this?

Hi Sebastian,

Sorry for the late reply, I already posted a comment yesterday, but it seems to have disappeared.

You can be sure that data is saved correctly and assigned correctly to the user in the JIRA database - otherwise you would not see it e.g. on the issue screen. The problem must be related to a specific problem when the timesheet tries to retrieve the data. To have a more detailed look, please provide the following information:

- your exact JIRA version

- database you are using (MySQL, Oracle, ...)

- can you see the respective work logs when using Reporting?

- did you modify parameters in the search mask (like the data range) - same result?

- can you try to configure your user in JIRA so that this user can log work for others, and then try to choose "All users" in the user picker of the search mask of My Timesheet - same result?

Best regards

Tobias

Hi Tobias,

thx for the reply, here the information

- JIRA v6.1#6144-sha1:2e50328

- ictime 3.1.4

- database MySQL

- yes all work logs are shown on Create Report

- just did and voila, changing to "All users" also shows my entries. Not working is the filter for myself :-(

I hope that helps to identify the problem

Cheers

Hi Sebastian,

We began seeing this same problem when we updated the ictime plugin to 3.1.4 on 1/27/2014: https://answers.atlassian.com/questions/256593/ictime-my-timesheet-fails

Hi Sebastian,

I posted a comment here:

https://answers.atlassian.com/questions/256593/ictime-my-timesheet-fails#fmanswer

Would you mind setting your jira sql log on enabled like described in that comment and send us the atlassian-jira-sql.log to jiraplugins@interconcept.de? Maybe that brings us closer to the solution.

Thank you!

Tim

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in Marketplace Apps

How to set up an incident workflow from the VP of Engineering at Sentry

Hey Atlassian community, I help lead engineering at Sentry, an open-source error-tracking and monitoring tool that integrates with Jira. We started using Jira Software Cloud internally last year, a...

1,375 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you