Message Custom Field (for edit) default value is reformatted after saving

I have a Message Custom Field (for edit) custom field to display a message on some screens. After setting the default value of this the content is reformatted and escaped making editing a pain. For example, if it set the value to be:

{panel}
(i){color:red} my message {color}
{panel}

After saving and going back in to edit it has been changed to:

<div class="panel" style="border-width: 1px;"><div class="panelContent">
<p><img class="emoticon" src="/images/icons/emoticons/information.gif" height="16" width="16" align="absmiddle" alt="" border="0"/><font color="red"> my message</font>
</p>
</div></div>

2 answers

I should add this is on an OnDemand instance

Are you editing the HTML when you modify it? I found I needed to reinput raw wiki markup again as it converts that to HTML after submission but does not then convert back when you want to edit. Bit of a pain!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in Marketplace Apps

How to set up an incident workflow from the VP of Engineering at Sentry

Hey Atlassian community, I help lead engineering at Sentry, an open-source error-tracking and monitoring tool that integrates with Jira. We started using Jira Software Cloud internally last year, a...

1,349 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you