Jitter notify shows notifications but the list is empty

I have installed jitter notify on 5.1 but when someone mentions me i see the count going up but the list is empty.

12 answers

1 accepted

Accepted Answer
1 vote

Update 2

Version 0.1.2 has been released that adds support for MS SQL Server. Get the new at the Marketplace (or use UPM to update).

Thanks everyone for the help resolving this issue. Please remember to rate the plugin (or update your rating if you already did so:)

Update 1

Here is the error that is causing MSSQL to fail reading the notifications:

java.sql.SQLException: ResultSet may only be accessed in a forward direction.

I will investigate and hopefully release a fix ASAP.

General Troubleshooting

There are two reasons that I am aware of that might cause notifications not being fired.

1. There is no SMTP server configured as outgoing mail for JIRA. This might cause JIRA not to fire social events like @mentions. But I will have to investigate to be sure.

2. The project does not have a Notification Scheme configured. If this is the case, then JIRA does not know the recipients for the event. We could add a default behaviour to overcome this limitation by sending notification to all watchers and participants regardless whether there is a notification scheme or not. But there might be a reason for the project not having a notification scheme so this would probably have to be optional.

If you have both SMTP server and Notification Scheme configure but are still not getting any notifications, then there is probably a bug that affects your browser. In that case, please provide browser information so I can investigate.

Thank you for taking the time to answer. I had indeed not set up a mail server. I have done that now but i still get empty notifications. I now receive the email from JIRA so email is set up correct. I do not have any notifications scheme set so you are right that it needs to be be set but for mentions it should not be necessary.

I am using Chrome 20.0.1132.

When i mention we see the number count up on the user mentioned.

It would also help me to know which database server you are using.

Thank you for the details. It does indeed look like notifications are being fired (since the count is correct), but the view is failing to display them to you for some reason. This might be caused because Notify is having trouble with your database type. Please tell me if there are any SQL errors in the logs. It might also be a problem with the web service. Can you try accessing $JIRA_PATH/rest/jitter-notify/1.0/notification.json in your browser and tell me the result? (where $JIRA_PATH is the URL to the root of your JIRA.)

I get {"status-code":500}

We use MSSQL 2005

No SQL errors in $JIRA_HOME\log\atlassian-jira.log

Also using MSSQL 2008 Standard

Hi, in my scenario I have notification schema setup and also the mail server as I'm receiving notifications by email to changes to issues. I assumed it was a config item under administration for notication schemes however couldn't find the option to add the jitter option in. Also I'm an an administrator of Jira so permissions shouldn't be an issue.

Thanks everyone for the help in identifiying this issue.

The issues is definitely SQL problems with MSSQL. Notify uses the Active Objects (AO) ORM provided in JIRA. I have seen problems with MSSQL in other plugins that use AO. This can usually be fixed easily if we can get access to the stacktrace. Unfortunately I don't have access to MSSQL server at the moment so it would be great if we can extract some logs. Then I can probably identify and fix the issue quickly.

This page might help with finding the logs: https://developer.atlassian.com/display/AO/Enabling+SQL+logging

@ranger: It just uses the standard notification schemes so there is no additional configuration needed. You should be all set. Do you also see the notification counter in the header of JIRA? (See first screenshot from @michaicph.)

If no logs can be extracted, then I will setup MSSQL and debug it from there. But I can't do that right now.

yes i see the notification icon with the count increasing though no information when you click it (blank notification page). What logs do you need to see and where can I locate them? Through Profiler I can see exec sp_execute 31,N'<user>'

There should be some lines in the logs containing the following string: AO_0BE43A_NOTIFICATIONS

Something like:

Caused by: java.sql.SQLException: Column not found: FOO in statement [SELECT LIMIT 0 10 * FROM PUBLIC.AO_0BE43A_NOTIFICATIONS WHERE FOO = 1, TO_USER = ? ORDER BY POSTED_DATE DESC]

You might need to enable logging on java.sql.* and net.java.ao.*

ok we managed to get the logs and we do see the exceptions you are talking about.

See bellow attachments

(atlassian-jira.log) (atlassian-jira-sql.log)

Thank you @donnib, this confirms the error. It looks like MSSQL can't deal well with offset when ordering the result set in descending order. I am looking for a workaround. Meanwhile, I have filed this in the AO project: https://studio.atlassian.com/browse/AO-358

Thank you for your patience.

I'm also getting the same issue after installing this plugin.

I'm also getting the same issue after installing this plugin.

Hi, it looks like a bug if the count goes up but nothing is displayed. Which browser are you using?

Also, does the list show a hint that there are no notifications or is it completely empty? Does it have some empty space or does it have no height?

I know there is notifications because i have tested this with another user where he mentions me.

@donnib: Do you have outgoing email server configured in JIRA? It might be that mention events are not fired unless that is the case but I will have to investigate.

Here are some screenshots :

Check my updated answer that includes a new version that should fix the problem. Let me know how it goes.

I can now confirm that the fix works. Thank you ;)

It's now showing the notifications which is great however not marking them as read after i click on them. When I click on the @ symbol whilst at the dashboard it shows the notifications then the number disappears however on click to another section of Jira (lets say the dashboard) the number re-appears showing 23 unread notifications.

@ranger: That is odd, every notification that you see should be marked as read after that. But this might be also a problem with the database. Unfortunately I am traveling so I can't have a look until I get back. But I will have a look as soon as I get back.

For me the number goes away even if i hit F5 in the browser so i guess that is the wanted functionality.

Please accept my answer if this is resolved.

Hi,

I've added Jitter plugin but the JIRA users in my organization just notify while anyone make mention to them, I need they notify by any JIRA activities related to them like issue commented , updated and assigned.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 11, 2018 in Marketplace Apps

You + one app + a desert island...

Hi all! My name is Miles and I work on the Marketplace team. We’re looking for better ways to recommend and suggest apps that are truly crowd favorites, so of course we wanted to poll the Community. ...

3,670 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you