Javascript not working

I tried the Javascript functionality by using your example in the documentation and it doesnt work for me.

Are there any known bugs?

J

7 answers

1 accepted

This widget could not be displayed.

Hi Andreas,

There is no known bug with javascript functionalities. Lots of people are using it :)

Certify yourself that you do no have line breaks within the javascript code.

I am attaching a file with a working template.

Best Regards

This widget could not be displayed.

Can you give more information about your problem? Some sample code which is not working?

This widget could not be displayed.

What is the message in your log?

This widget could not be displayed.
I tried the first example in the documentation:
%{(new Date()).getDate() + "/" + ((new Date()).getMonth()+1) + "/"
+ (new Date()).getFullYear()}
I use a docx as a template!
This widget could not be displayed.

in the atlassian-jira log I don't get a logging for log level DEBUG. I don't see a specific log for the plugin.

The output on the generated document is the non-processed command.

This widget could not be displayed.

Ensure that you included the libraries

Example: <%@ page import="java.util.Date" language="java" %>

Are we talking about the same? In the documentation for the plugin xporter it is not mentioned that you can use Java code. They state only, that JavaScript is possible.

This widget could not be displayed.

The line breaks were in fact the problem.

I have another problem though with Custom Fields: How do I escape a space in a FieldName.

e.g. If I use a Field ${Ticket Nr} in a js expression, it is not rendering the code correctly, but breaking after the space.

The original problem is solved though!

Thank you!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 22, 2018 in Marketplace Apps

How a Marketplace app tech team is achieving gender diversity

Hello! My name is Genevieve Blanch, and I'm the Marketing Manager at RefinedWiki, creators of apps to give teams the tools to customize Atlassian platforms. Currently, 44% of the tech team at Re...

432 views 3 17
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you