JQL error: "A value provided by the function 'hasTestCoverage' is invalid for the field 'issue'."

Several of the JQL methods seem to indicate they are invalid for the 'issue' field. For example:

 

project = cdev and issue in hasTestCoverage()

project = cdev and issue in coveredByTestCasesHavingField("status", "Draft")

project = cdev and issue in hasTestResult()

project = cdev and issue in hasAllLastTestResults("Pass") <-- works with "Fail"

project = cdev and issue in hasAnyLastTestResults("Pass") <-- works with "Fail"

 

I've been able to use some, but the above all give me the "invalid for ... 'issue'" error.

2 answers

Hi Michael,

I tried to reproduce this issue here on my environment with no success. For example, the first query using hasTestCoverage() works for me. I'll help you to troubleshoot this problem. smile

What JIRA and Kanoah Tests version are you using? Could you please post a screenshot of your error message?

Cheers,

Vitor

We are using JIRA server 6.3.4 with a trial license of Kanoah version 3.2.0.

 

jira_issue_error.png

Awesome, thank you.

I'll try to reproduce here and keep you posted soon about the results.

Cheers,

Vitor

Hi Michael,

I've setup an environment here using your JIRA/Kanoah Tests versions but I couldn't reproduce the issue.

Could you please check your server log (<jira-install-dir>/log/catalina.out)? Maybe we can find something useful there displaying exactly what is the error.

Also, which Java version are you using?

If you prefer, you can send me the logs through our support site or by email (vitor.pelizza@kanoah.com).

Thanks,

Vitor

I don't see much related to Kanoah. There are a few REST API errors that I think correspond to our experimenting with the API but aren't actual plugin errors. And I also see this line twice – once yesterday, once today:

 

2017-03-16 10:23:23,590 http-bio-8080-exec-6 ERROR mvanorma 623x62041x1 1t3n5ib 10.52.6.115,10.1.1.27 /issues/ [jira.groovy.jql.ScriptedJqlFunction] Fatal error in scripted JQL functions - try disabling and re-enabling the Script Runner plugin

Hmm... curious.

How about your Java version, is it Java 7 or 8?

Sorry, we're using Java 1.8.0_11

Hi Michael,

I'm still trying to reproduce this error without success. I've tried with PostgreSQL and MySql databases, Java 8 and JIRA 6.3.4.

What is your database type?

And, is it possible to disable some other add-ons and try again? Maybe it is a conflict issue.

Cheers,

Vitor

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Marketplace Apps

Three tips for boosting your board's efficiency with Story Maps

Trello is one of the most effective tools for driving your sprints. It's customizable for every Agile team and product owners and Scrum masters (SM) love it. However, Agile teams often struggle with:...

849 views 2 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you