JMWE post-function on Jira Core

Hi,

i tried to code a postfunction (set field value (JMWE add-on) to remove one of the multichoise/checkbox options.

def a = []
def b = ["a","b","c"] // b ... [a, b, c]

a = issue.get("fieldname") // get an ArrayList with all selected options
// a ... [a, b, c]

a.remove("b") //does not work! *1*
a.remove(1) //removes the "b"

b.remove("b") //does work?!? why not with ArrayList a[]?

// since remove(index) works I tried to get the Index of "b" entry
// b can have the position/index 0 or 1 (depends if "a" is selected)

x = a.indexOf("a") // -1
x = a.indexOf("b") // -1
x = a.indexOf("c") // -1

x = b.indexOf("a") // 0
x = b.indexOf("b") // 1
x = b.indexOf("c") // 2

// myDesk.TableFlip()

 

Can anybody explain me the diff?

 

Thanks a lot

Salmir

0 answers

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

255 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you