Is there a ScriptRunner 3.X for Confluence?

The Confluence Scriptrunner plugin page has been updated to indicate that "Script Runner for Confluence has merged with Script Runner for JIRA.", as of 3.X, which then directs you to this page: https://jamieechlin.atlassian.net/wiki/x/CAABAg

The problem is that when I manually install the ScriptRunner JAR in Confluence it tells me it's incompatible, which is contrary to the information available at the following locations:

I'm fine if ScriptRunner is not available for Confluence, though that's uber annoying given that I use it extensively to automate admin functions. If that's the case however I'd really love to see the false hope removed from the marketplace, and perhaps some indication so that someone else doesn't have to waste 2 hours trying to figure this out.

edited July 27th, 2015 to add in specific ScriptRunner version information to the question.

3 answers

1 accepted

0 vote

It hasn't been intentionally prevented from working with confluence. I don't know what the issue is exactly... we don't have a CI build for SR in confluence so it doesn't greatly surprise me.

The problem with providing it for confluence is we need to have a decent amount of built-in "content", plus good documentation, which sadly we haven't had time to do thus far, or keep up to date the existing content. It's not really acceptable to put it out there and hope for the best. However it's hard to see how this could be done as a free plugin.

As you mention it's frustrating that it's out there and doesn't work, so I've removed the listing on marketplace.

Thanks Jamie. That's all that's needed. I'll buy the Bob Swift one in the future.

0 vote
Steven Behnke Community Champion Jul 27, 2015

I helped someone here: Integrating Script Runner with Confluence 5.7. If you look at my comments in my answer, you might notice I am specifically using 2.1.3, which doesn't thrown any errors. I'm not sure what this means.

The Confluence support for Script Runner has always been low, so it doesn't surprise me if it falls out of date.

Correct. I saw your answer in my search prior to posting this question. The purpose of this question is specifically to figure out what the heck they're on about with version 3.0 Thank you for your response though!

I'll edit my question to make a bit more sense.

There is also the Scripting for Confluence add-on which is a supported plugin with an Atlassian Verified designation that works on Confluence Server. It supports scripting languages like Groovy, BeanShell, Gant, Jython and Javascript.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published 4 hours ago in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

26 views 0 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you