I've installed the addin but when I click on the 'Story Map' Menu I get a 404 Not Found error

I've checked your install instructions and it all seems to be set up ok

Jira 5.1.6

Greenhopper 6.1.1

9 answers

1 accepted

This widget could not be displayed.

Hi

please excuse my late replay - this forum was not yet related with our ticketing system :( but from now on it is under observation!

Currently the system calls a web service at the same port as the users request is bound. That means if this port is not available at the system's localhost, it leads into an 404 error. We will change this behavior within version 2.0, which will be released in two week.

Sorry for this constraint!

But if you think it is another issue, please provide the stack trace of your 404.

cheers,
Florian


This widget could not be displayed.

Hi Darren, Hi Bernd,

the version 2 has been released and the routing issue is solved. Just update and have a try ;)

Florian

This widget could not be displayed.

Hi!

I have a similar issue. I am using JIRA 5.2.4 on Ubuntu. JIRA is listening on ports 8980 but I used iptables to reroute incoming port 80 to that port.

If I click on story map I am getting the Oops page, but when I specify my port 8980 in the URL all is fine...

This widget could not be displayed.

I happily confirm that it is well now. The first release of v2 did not yet do it, but the latest fix is fine.

A very nice tool!

This widget could not be displayed.

The 404 problem is happening to us with Jira v5.0.7#734-sha1:8ad78a6 and a trial version we just downloaded (v 2.2.0) via the Adminstration page.

We have uninstalled and reinstalled several times. We can Enable the plugin, but trying to Configure or access via the Story Map menu generates a 404.

Any suggestions?

This widget could not be displayed.

I'm also getting a 404 error when accessing via the Story Map menu :

Could not find servlet for: /plugins/servlet/bit/FEN.storymap

We'd really like to evaluate this product - please help.

This widget could not be displayed.

We have the same issue. We get 404 when trying to access the "Story Map" menu.

We are using

JIRA 5.0.3

AgileStory Map plugin 2.2.0

Greenhopper 6.1.6

We see following exceptions in the logs corresponding to this when we try to access the "Story Map" menu.

/plugins/servlet/bit/SOA.storymap [atlassian.plugin.servlet.DefaultServletModuleManager] Unable to create servlet

com.atlassian.util.concurrent.LazyReference$InitializationException: java.lang.NullPointerException

at com.atlassian.util.concurrent.LazyReference.getInterruptibly(LazyReference.java:152)

at com.atlassian.util.concurrent.LazyReference.get(LazyReference.java:115)

at com.atlassian.plugin.servlet.DefaultServletModuleManager.getServlet(DefaultServletModuleManager.java:313)

..............

Caused by: java.lang.NullPointerException

at com.atlassian.plugin.module.ClassPrefixModuleFactory.createModule(ClassPrefixModuleFactory.java:32)

at com.atlassian.plugin.module.PrefixDelegatingModuleFactory.createModule(PrefixDelegatingModuleFactory.java:99)

at com.atlassian.plugin.servlet.descriptors.ServletModuleDescriptor.getModule(ServletModuleDescriptor.java:50)

at com.atlassian.plugin.servlet.DelegatingPluginServlet.<init>(DelegatingPluginServlet.java:33)

at com.atlassian.plugin.servlet.DefaultServletModuleManager$LazyLoadedServletReference.create(DefaultServletModuleManager.java:430)

at com.atlassian.plugin.servlet.DefaultServletModuleManager$LazyLoadedServletReference.create(DefaultServletModuleManager.java:416)

at com.atlassian.util.concurrent.LazyReference$Sync.run(LazyReference.java:326)

at com.atlassian.util.concurrent.LazyReference.getInterruptibly(LazyReference.java:146)

... 127 more

This widget could not be displayed.

Hello? Anybody home?

This widget could not be displayed.

Hi,

404 means the 'FEN' project can not be found.

are you sure that the project with the key 'FEN' really exists and that you have permissions (read/write) to this project.

Otherwise please provide the stack trace (the whole error page)

Cheers,

Florian

Hi Florian - We're also experiencing the same error when we click on the "Story Map" menu option...

Could not find servlet for: /plugins/servlet/bit/TOOL.storymap

Yes, "TOOL" is a valid Project Key that I have Administrator access to. We're running JIRA 5.0.2 with version 2.2.0 of the Agile StoryMap Plugin.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 22, 2018 in Marketplace Apps

How a Marketplace app tech team is achieving gender diversity

Hello! My name is Genevieve Blanch, and I'm the Marketing Manager at RefinedWiki, creators of apps to give teams the tools to customize Atlassian platforms. Currently, 44% of the tech team at Re...

451 views 3 17
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you