How to increase font size in LaTeXMath plugin?

How to increase font size in LaTeXMath plugin?

8 answers

Globally, or just for one macro? Are you using the external renderer?

To follow up on this, I would like to increase the font size globally. I have already modified the LaTeX header in the configuration to be

\documentclass[12pt, fleqn]{article}

but this still renders too small. My understanding is that, in 'normal' LaTeX, I would need to install the 'anyfontsize' package. Is there I can make the size bigger when in embedded in Confluence?

Thanks!

To use a package you should just add \usepackage{anyfontsize} to the latex header (just after the other usepackage entries). The package will install automatically if you are using MiKTeX in Windows and the install automatically option is enabled as described here.

Thanks @TenSixTwofor the quick response and happy New Year. To clarify, I'm not using LaTeX on my windows machine at all, and my Confluence instance is being hosted by CloudShards.net(I believe on a linux instance; not sure if it's Ubuntu). May I infer from your answer that I need to install an external renderer on the server, but that IF I do that, then just adding \usepackage{anyfontsize} to the header will automatically install it and then I can move forward?

Thank you.

No problem and Happy New Year to you too.

Installing the package depends on your linux distribution and latex distribution. If you are using Ubuntu and TexLive, then you can run the following: "apt-get install texlive-latex-extra". Using (or activating) the package is done with the usepackage command. Does that clear things up? You could try using the the package first and see if that works, it may already be installed on your machine.

Great, I ran it and added \usepackage{anyfontsize} to configuration header. However, it didn't work and when I saved the configuration, I got this error: The dvipng executable could not be found at the path given.

Are you certain that texlive is installed on the server and that LaTeX Math is set up to use the "external renderer" ? If so, try ignoring the error that occurs when you save the configuration and see if things work anyways. Otherwise please let me know what error occurs when the macro fails to render.

Assuming you want to increase the font sizes globally, I recommend applying one of the following changes to the LaTeX header in the LaTeX Math settings.

1. Change

1
\documentclass{article}

to

1
\documentclass[12pt]{extarticle}

This will require the extsizes package, will will be installed automatically if using MiKTeX with the right options. Otherwise it will need to be installed manually (run "apt-get install texlive-latex-recommended" in ubuntu).

2. Add \fontsize{12}{14} to the end of the LaTeX header.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Marketplace Apps

Three tips for boosting your board's efficiency with Story Maps

Trello is one of the most effective tools for driving your sprints. It's customizable for every Agile team and product owners and Scrum masters (SM) love it. However, Agile teams often struggle with:...

824 views 2 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you