How to create import configuration on insight ?

Hi,

I would like to create my custom import configuration using groovy. I have checked the documentation , but I do not know how to install the insight jar. Does it come from the obr ? If so, how to install it ?

Do I really need to create an add-on or can I simply run a groovy script ? 

Is there an existing full example somewhere ?

Thanks,

Antoine

1 answer

1 accepted

0 vote

Hi Antoine,

Yes you need to create a separate add on for this. The documentation you refer to has a example implementation link at the bottom.
The .jar file can be extracted like any zip file, you can read more about it at https://community.atlassian.com/t5/Jira-questions/how-to-extract-jar-from-obr/qaq-p/216436

Best Regards
Alexander

Hi Alexander, thanks for your quick answer. 

So I have put the dependency in the pom.xml and imported the jar. I then tried to run the script of the ImportModuleConfiguration with only the import lines. But when I ran the full script to give it a try, Insight disappeared from jira. 

I restarted jira and Insight is still not loaded. I have tried this workaround without success. 

These are the errors in the logs at the time I ran the sript (I'm not sure how to see the errors upon restart) : 

2017-11-09 16:34:11,804 http-nio-8300-exec-14 ERROR berrya 994x2568x1 13svroq 10.76.141.20,10.198.47.248 /secure/InsightConfigure.jspa [c.a.j.web.dispatcher.JiraWebworkActionDispatcher] Exception thrown from action 'InsightConfigure', returning 404 
WebworkConfigurationNotFoundException{class=class webwork.config.XMLActionConfiguration, message='No such view mapping', name='InsightConfigure.actionRoles.actionRoles'}

And for a lot of modules : 

2017-11-09 16:35:11,383 JIRA-Bootstrap INFO [c.a.plugin.manager.DefaultPluginManager] Plugin system earlyStartup begun
2017-11-09 16:35:15,256 JIRA-Bootstrap ERROR [c.a.plugin.parsers.XmlDescriptorParserUtils] There were problems loading the module 'ao' in plugin 'Insight'. The module has been disabled.
2017-11-09 16:35:15,257 JIRA-Bootstrap ERROR [c.a.plugin.parsers.XmlDescriptorParserUtils] Cannot find ModuleDescriptor class for plugin of type 'ao'.
com.atlassian.plugin.PluginParseException: Cannot find ModuleDescriptor class for plugin of type 'ao'.
at com.atlassian.plugin.DefaultModuleDescriptorFactory.getModuleDescriptor(DefaultModuleDescriptorFactory.java:64)
at com.atlassian.plugin.parsers.XmlDescriptorParserUtils.newModuleDescriptor(XmlDescriptorParserUtils.java:46)
at com.atlassian.plugin.parsers.XmlDescriptorParser.createModuleDescriptor(XmlDescriptorParser.java:171)
at com.atlassian.plugin.parsers.XmlDescriptorParser.configurePlugin(XmlDescriptorParser.java:141)
at com.atlassian.plugin.loaders.SinglePluginLoader.loadPlugin(SinglePluginLoader.java:139)
at com.atlassian.plugin.loaders.SinglePluginLoader.loadAllPlugins(SinglePluginLoader.java:88)
at com.atlassian.plugin.loaders.ClassPathPluginLoader.loadClassPathPlugins(ClassPathPluginLoader.java:53)
at com.atlassian.plugin.loaders.ClassPathPluginLoader.loadAllPlugins(ClassPathPluginLoader.java:61)
at com.atlassian.plugin.loaders.PermissionCheckingPluginLoader.loadAllPlugins(PermissionCheckingPluginLoader.java:28)
at com.atlassian.plugin.manager.DefaultPluginManager.earlyStartup(DefaultPluginManager.java:548)
at com.atlassian.jira.plugin.JiraPluginManager.earlyStartup(JiraPluginManager.java:119)
at com.atlassian.jira.ComponentManager$PluginSystem.earlyStartup(ComponentManager.java:641)
at com.atlassian.jira.ComponentManager.quickStart(ComponentManager.java:196)
at com.atlassian.jira.ComponentManager.start(ComponentManager.java:165)
at com.atlassian.jira.upgrade.PluginSystemLauncher.start(PluginSystemLauncher.java:47)
at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$postDbLaunch$2(DefaultJiraLauncher.java:154)
at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrEnqueue(DatabaseConfigurationManagerImpl.java:304)
at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrWhenDatabaseActivated(DatabaseConfigurationManagerImpl.java:199)
at com.atlassian.jira.startup.DefaultJiraLauncher.postDbLaunch(DefaultJiraLauncher.java:146)
at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$start$0(DefaultJiraLauncher.java:105)
at com.atlassian.jira.util.devspeed.JiraDevSpeedTimer.run(JiraDevSpeedTimer.java:31)
at com.atlassian.jira.startup.DefaultJiraLauncher.start(DefaultJiraLauncher.java:103)
at com.atlassian.jira.startup.LauncherContextListener.initSlowStuff(LauncherContextListener.java:157)
at java.lang.Thread.run(Thread.java:745)

 

Any idea ? I would really like to retrieve my insight configuration because I just worked a lot on it. That would save the day (I know this was dumb on me...).

Thanks, 

Antoine

I missed this line as well : 

 The following plugins failed to load:
Insight: OSGi plugins cannot be deployed via the classpath, which is usually WEB-INF/lib.
URL is: jar:file:/appjira/logiciels/list/jira/atlassian-jira/WEB-INF/lib/insight-5.1.4.jar!/atlassian-plugin.xml

I fixed the issue, sorry for the disturbance. I deleted the jar on the server and restarted jira, and it worked.

Regards,

Antoine.

Hi Antoine,

Glad that you got it up and running again.

Best Regards
Alexander

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Marketplace Apps

Three tips for boosting your board's efficiency with Story Maps

Trello is one of the most effective tools for driving your sprints. It's customizable for every Agile team and product owners and Scrum masters (SM) love it. However, Agile teams often struggle with:...

840 views 2 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you