How Test My Jira Plugin on Versions lower than 4.4 --version won't go lower than that?

For some reason in my test environment when I call atlas-debug --version 4.1.1 as example the Jira version always gets installed as 4.4? Any ideas why this is happening? I'd really like to test my plugin all the way to 4.0 if possible?

Thank you,

Steve

2 answers

0 vote
David Simpson Community Champion Jul 04, 2012

Download an older version of the SDK -- something that's closer to the vintage of the product you wish to test against.

Old SDK versions go here to die:
http://maven.atlassian.com/public/com/atlassian/amps/atlassian-plugin-sdk/

Perhaps try something < v3.8

Hi Steve,

what i am suggesting you is not the technical way.its a trick

you have any plugin developed as 4.0. Copy that plugin to any specific location

simply replace src and pom.xml as required and then you can run the atlas-run you will get the enviornment for 4.0.

for api change you can refer the checkup.atlassian.com.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

74 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you