Getting an 404 trying to upload document

Hi - sorry but I have a strange one.

Trying to add a document an getting an 404 after selecting it in the explorer menu...

7 answers

I have the same error here. After selecting the file I want to add, I get the following message:

Cannot attach file CV-HighLevelArchitecture.docx: Unknown server error (404).


I have the same error here. After selecting the file I want to add, I get the following message:

"Cannot attach file CV-HighLevelArchitecture.docx: Unknown server error (404)."

After investiguation, the call generating the 404 error is the following:

http://192.168.0.99:8080/rest/StonikByteProjectDocsPlugin/1.0/AttachTemporaryDocument?filename=CV-HighLevelArchitecture.docx&size=35837&atl_token=BV3B-5349-CI5W-XCPV%7Cbd5c42603f1c3289a11c82b32dc1710da25bee25%7Clin&projectId=10000

Hi,

We will look into it.

Can you please provide the following info:

- which operating system are you using?

- is OS 32-bit or 64-bit?

- which browser and which version of the browser are you using?

This kind of issues should be reported on the Bitbucket repository of Documents (https://bitbucket.org/StonikByte/documents-add-on/issues?status=new&status=open).

Thank you,

Danut

Even if I was unable to reproduce it on my configuration (Win7 x64 with Chrome, IE 9), it may be related to the fact that the document contains "-" in its name.

Can you please replace the "-" and try again?

Danut.

I got the same error after removing the "-" from the filename.

In fact, I tried with many documents without success.

Operating system: windows 7-64 bits (client), ubuntu (jira server).

Browser: Chrome Version 24.0.1312.52 m

I created a bitbucket issue.

Thank you

Whenever you have a minute, could you please check that all modules for the Document plugin are still enabled.

I can reproduce this if the rest-service-resources module is disabled.

Hello - sorry for the delay.

We are running JIRA 5.2.4 on Ubuntu 12.04 LTS 64 bit, and all modules are enabled...

Sorry, for asking you so many questions :( ...

Could you please tell me if you use http://192.168.0.99:8080 or http://192.168.0.99:8080/jira to access JIRA?

Does the path you are using to access JIRA is the same as the base URL in the general configuration page?

Thank you!

I promise this is the last question ... at least for today :):(

Could you please tell me if you are using Tomcat or other web server?

Thank you.

Hi,

No prob for the questions. I understand you need information to debug the problem.

32 of 32 modules are enabled.

My base url is http://192.168.0.99:8080 and I use http://192.168.0.99:8080 to access JIRA.

Thank you,

I'm using jira standalone on linux ubuntu.

I believe this runs behind tomcat (which is why I'm accessing jira by the port 8080).

Feel free to ask more questions if needed.

Thx

The issue is fixed in version 1.1.1 released on January 23, 2013.

Yippeeee! Certainly fixed it for me...

Great stuff. Five Star.

I confirm the fix on my side.

Support for this plugin is great.

Thank you !

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Thursday in Marketplace Apps

You + one app + a desert island...

Hi all! My name is Miles and I work on the Marketplace team. We’re looking for better ways to recommend and suggest apps that are truly crowd favorites, so of course we wanted to poll the Community. ...

174 views 3 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you