Fail to install team calendar for confluence?

I have tried many times to install team calendar, but it always fails, The confluence is version 5.2.3

An error occurred while installing the add-on. Please refer to the logs for more information

In log:

2013-08-27 10:20:12,515 ERROR [UpmAsynchronousTaskManager:thread-2] [upm.manager.install.ObrPluginInstallHandler] logUnsatisfiedRequirements OBR resolver has 1 unsatisfied requirements for installing plugin_553621139557884204_team-calendars-4.0.1.obr

-- referer: http://locahost:8090/plugins/servlet/upm | url: /rest/plugins/1.0/ | userName: admin

2013-08-27 10:20:12,516 ERROR [UpmAsynchronousTaskManager:thread-2] [upm.manager.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.apache.xml.serialize)(version>=2.9.0))

-- referer: http://locahost:8090/plugins/servlet/upm | url: /rest/plugins/1.0/ | userName: admin

2013-08-27 10:20:12,519 WARN [UpmAsynchronousTaskManager:thread-2] [atlassian.upm.manager.PluginInstallationServiceImpl] installPlugin Plugin installation failed: Failed to resolve plugin dependencies within OBR [plugin_553621139557884204_team-calendars-4.0.1.obr]. Please see the logs for more detailed information.

-- referer: http://locahost:8090/plugins/servlet/upm | url: /rest/plugins/1.0/ | userName: admin

2013-08-27 10:20:12,520 ERROR [UpmAsynchronousTaskManager:thread-2] [atlassian.upm.manager.PluginInstaller] execute Failed to install plugin 'team-calendars-4.0.1.obr': Failed to resolve plugin dependencies within OBR [plugin_553621139557884204_team-calendars-4.0.1.obr]. Please see the logs for more detailed information.

-- referer: http://locahost:8090/plugins/servlet/upm | url: /rest/plugins/1.0/ | userName: admin

3 answers

Hi there,

Unfortunately, it is quite hard to determine the cause of the issue just from the provided stack trace snippet. However here are the points that you need to check as the cause of the issue.

  • Ensure that the "Server Base URL" configured correctly. Judging from your stack trace u try to access Confluence trough http://localhost:8090/ so ensure that the Server Base URL configured the same
  • Ensure that JDK used by Confluence is supported which is JDK 1.7
  • If you are using MySQL, ensure that you have increase the maximum size as describe here

Hope it helps.

Cheers,
Septa Cahyadiputra

1 vote

Hey Sanigo,

Generally, the error displayed regarding the "unsatisfatory requirements" are related that you try to install a version of the plugin, which is not compatible with the instance. So, can you make sure that your Team Calendars version were matching the correct one from confluence?

Cheers,

Giu

If problem remains even after trying out the above and your Universal Plugin Manager (UPM) version is not in the latest version, try to upgrade UPM to the latest version first and then re-attempt the installation manually by downloading the plugin file directly from Marketplace and upload it into Confluence.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

361 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you