Exception seen when tried to look at 'Issue -> History': Error rendering 'com.atlassian.jira.plugin.system.issuetabpanels:changehistory-tabpanel'

[jira.plugin.issuetabpanel.IssueTabPanelInvokerImpl] Exception thrown while trying to call getActions() for com.atlassian.jira.plugin.system.issuetabpanels:changehistory-tabpanel (Display issue change histories)

2 answers

Do you have more logs? There is normally a "caused by" clause somewhere.

Is it happening to all users? all issues? or just for one specific scenario?

Was this issue moved or cloned? What version are you using? Did you upgraded jira recently?

Maybe you should do some queries against the database and check if there is indeed a history for this issue or not.

Yes, I do. It is happening for all users and all issues. Our Jira version is 5.0.4. I have updated UPM recently. I have checked the history on lots of other issues which I am aware that the history exists.

Maybe you want to run Hercules to see if he finds a KB.

Go to <your JIRA url>/plugins/servlet/stp/view/ and click the third tab. Rather than that, I would first try to reindex JIRA, restart it, try to rebuild the indexes as described here: https://confluence.atlassian.com/display/JIRAKB/Unable+to+Rebuild+JIRA+Index

But it all depends how much you want to try by yourself before contacting Atlassian Support. I'm pretty sure they know this problem already.

Try Hercules and if he doesn't find anything, open a support request with Atlassian.

Or, paste the whole exception in your logs here, maybe will click something.

Luzia,

I had an update of UPM which when updated broke the Activity>History. I removed the upm jar file from the $JIRA_HOME/plugins/installed-plugins directory and restarted the server. That solved the problem.

That's quite strange :( UPM does not anything to do with issue history.

Not sure, Renjith. I have raised the same issue with Atlassian Support and they mentioned that the Field Security plugin is also incompatible with the latest UPM version. Whatever might be the reason, after uninstalling the update, I no longer see the issue.

I had the same exception after updating Atlassian Universal Plugin Manager from 2.18.4 to 2.18.5.
After a restart the exception disappears and you will see the history entries.

Didn't work for me

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Jul 10, 2018 in Marketplace Apps

If you’re an Atlassian app developer, you’ll want to know about Atlas Camp!

This September 6-7, hundreds of Atlassian App developers will flock to Barcelona Spain to build skills, discover product roadmaps, meet face-to-face with the Atlassian team, and learn how to extend t...

175 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you