Error reading macro xsd-image

Hello,

I am using an evaluation/trial version of Confluence and a trial version of the Avisi plugin for XSD files.

addon-nl.avisi.confluence.plugins.xsdviewer

When I try save the settings of the xsd-image macro, an error message is displayed. It reads:
Error rendering macro 'xsd-image' : An unexpected error has occurred, please create a bug at https://bitbucket.org/avisi/xsd-viewer/issues

14 answers

This widget could not be displayed.

Are there any messages in the logfiles? i.e. catalina.out

This widget could not be displayed.

To further clarify my question/request, I have found out that we have fully licenced version of Confluence 5.

This widget could not be displayed.

Are there any messages in the logfiles? i.e. catalina.out

This widget could not be displayed.

Does the filename contain special characters? e.g. a "+"?

This widget could not be displayed.

Hello Nabil,

Since the server on which Confluence is installed is located remotely, I have posed the question to the co-administrator. I will get back to you shortly.

Please note I have subsequently tried uploaded a different XSD file only to obtain the exact same error message.

This widget could not be displayed.

No, the filename does not contain such a character

This widget could not be displayed.

Note: The actual filename is VanillaMBU_v11.2.xsd

This widget could not be displayed.

Log file shows this message:

2013-03-11 17:30:27,508 WARN [http-8090-10] [atlassian.plugin.webresource.DefaultResourceDependencyResolver] resolveDependencies Cannot find web resource module for: com.atlassian.analytics.analytics-client:js-events

-- url: /plugins/servlet/notifications-miniview | userName: jlebourhis | referer: http://10.120.100.6:8090/display/XSD/Generic+Merchant+Bulk+Upload+XSD

This widget could not be displayed.

So, any further suggestions on how to resolve the problem, please?

This widget could not be displayed.

Are you sure you have the latest version of that plugin?

This widget could not be displayed.

Hello Nabil,

I just downloaded the plugin yesterday from the Avisi site, so it should be the latest?

This widget could not be displayed.
This widget could not be displayed.

Can you please post the xsd so we can try it out? You are also free to raise an issue in the xsd viewer's issue tracker at https://bitbucket.org/avisi/xsd-viewer/issues.

This widget could not be displayed.

Can you please post the xsd so we can try it out? You are also free to raise an issue in the xsd viewer's issue tracker at https://bitbucket.org/avisi/xsd-viewer/issues.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 22, 2018 in Marketplace Apps

How a Marketplace app tech team is achieving gender diversity

Hello! My name is Genevieve Blanch, and I'm the Marketing Manager at RefinedWiki, creators of apps to give teams the tools to customize Atlassian platforms. Currently, 44% of the tech team at Re...

487 views 3 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you