Edit Mode splits Edit-Screen (confluence 4.2) in two parts if not using global theme settings

To get rid of the right sidebar (don't like to click it away on every page change) one must change the
settings which onle works by disable global settings. Unfortunately, that splits the edit screen into two parts. Left side shows the Menubar only, right side all the rest (starting with the toolbar). Is there another way to disable the right sidebar?

12 answers

1 accepted

Accepted Answer
0 votes

I mentioned the issue does not appear to be caused by user installed plugins. Here's a workaround to get rid of the split mode view when editing a wiki page:

1) Go to Space Admin page of the space

2) Modified themes to be other than the globally defined theme

I'm assuming when you say intranet theme, you mean the pre-packaged themes that ship with Confluence.

Thank you. it's not really what i wanted to hear because some people here wish to use this intranet theme plugin which is visible in the 'user instaled plugins' part. User want to have it because of the possibility to show the page tree in form of a menue. Anyway, guess i will not get a solution on that for the moment and therefore people have to live with the sidebar.

Thanks a lot

regards

Mario

It might be related to the web browser. Perhaps you could try from other browser and check. Otherwise, the plugin might not be compatible with Confluence version 4.2.

i was of course trying it out in IE, Chrome and Firefox. I got the problem on all Browsers we use here.

If you say it may not be compatible with 4.2 The plugin shows that the newest Version V2.4 is compatible with confluence 4.2-4.2.1 (we are running 4.2!)

My last test was installing firefox and getting the confluence page without changing anything in firefox (original firefox settings) and i got the same error. The only thing i can not control is our Firewall and our proxy settings as i can not call anything without

As we have this problem in all machines in the company, it is not caused by my own computer. Fortunately i was able now to upload a screenprint of my problem. I would be suprised if we would be the only company having this company or is there nobody out using this intranet theme plugin?

Hello,

I'm seeing the same behaviour and running Confluence 4.2.12; I've enabled safe mode, so user installed plugins have been disabled. Editing a wiki page shows the split view mode for the space that is using the same global settings theme. If I modified the settings theme for the space and differs from the default theme, I do not get the split view mode. Thanks.

Hector thank you but i don't understand very well what you did or mean. Intranet theme is a 'as you said a user installed plugin'. Why did you disable it? What do you mean with'editing a wiki page (which wiki page).

My problem is caused by the intranet theme itself. If i disable it, it will not work anymore and i must take another theme (another way to solve the problem :-) )

Can you give me little bit more explanation (sorry, my original language is german)

I'm seeing this after upgrading to 4.3.7 from 3.5.6. It's super-annoying. I believe it only crops up when a Space is using the "Global Look and Feel", and goes away when using the Documentation Theme.

Do you have any custom html that you add to all your wiki pages in your global templates e.g. header, footer, etc.. ? There may be html code that are no longer compatible with the latter version of Confluence; removing the custom html fixed my issue.

Hi yeah, looking into this more closely we have a ton of CSS customization, as well as Custom HTML. I've got our CSS guy looking into it. Thanks!

The problem with the Intranet theme will not be a problem anymore after changing to Confluence 5.x as Intranet Theme is no longer supported on Confluence 5 (does not work anymore)

Ha, thanks Mario, we're still dealing with the fallout of upgrading from 3.x to 4.x and the loss of Wiki Markup. Don't think I'm ready to jump another rev and break more stuff just yet.

yeah, as i told, we can not use intranet theme in confluence 5 therefore my request is not on the scope anymore. Just forget it.

Thanks

UGH - I found a fix but it must be applied in Space Stylesheets, as that is the only way to override this broken CSS that is embedded in the template:

.contenteditor #main .edit#content {
    display: block;
}

Super. Lame.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Thursday in Marketplace Apps

You + one app + a desert island...

Hi all! My name is Miles and I work on the Marketplace team. We’re looking for better ways to recommend and suggest apps that are truly crowd favorites, so of course we wanted to poll the Community. ...

143 views 3 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you