Duplicate code not shown in Sonar for Bitbucket server Edited

Duplicate code is not marked in bitbucket server pull requests if test coverage is turned off.

If test coverage is turned on then both the coverage and duplicates are shown correctly. 

 

Is this an issue with the plugin and what can i do to further check where the problem is?

 

sonar4stash version 1.13.0
bitbucket version 5.2.3

 

1 answer

1 accepted

Hi,

Thanks for your feedback.

You are right, I was able to reproduce this. We will release a bug fix very soon. I'll reply back here once it is out!

Best regards,
Michael

Hi,

We've just released a bug fix version 1.13.1 which solves this problem.

Thanks again for reporting it.

Best regards,
Michael

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

166 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you