Display footnote macro no longer working

All pages where the display footnote macro is used are no longer working and show the error message:

Error: No group with name {footnoteId}

instead of the page content.

Removing the macro shows the content as expected.

We are using:

- Confluence server: 6.1.3

- Adaptavist footnote plugin: 2.6.0

Please, help fixing this issue ASAP.

1 answer

1 accepted

0 vote
Thomas Schlegel Community Champion Jun 06, 2017

Hi Rosario,

do you also have the Content Formatting Plugin from Adaptavist? And installed the latest version?

With version 6, they deployed a new footnote macro with that Add on and disabled the old one automatically.

Yes, I have also that plugin. This must be the reason. I missed any hint from Adaptavist on this chage...

Can you explain me how can I fix the issue then?

Thomas Schlegel Community Champion Jun 06, 2017

Is the new footnote macro enabled? Maybe the installation stopped the old one and not enabled the new one?

There is an announcement for that:

http://www.adaptavist.com/w/update-footnotes-for-confluence-users/ 

 

Well, the update of Content Formatting to v. 6.0.0 did not work as described in the link.

I have both plug-ins and after the upgrade the Footnote plug-in is still "active" but gives the metioned error and I the Content Formatting plug-in seems not to bring-in the new macros.

I tried to manually disable the Footnote plug-in but this results in "unknown macro" messages in all pages using the plug-in and if I edit the page I find no macro for footnote...

Who can help fixing the issue?

I have opened a support ticket.

Thanks for pointing out our product support @Thomas.

I've solved the issue with Rosario. Essentially for some reason the Footnotes modules were disabled.

After enabling the modules it worked perfectly.

Thomas Schlegel Community Champion Jun 08, 2017

great, you're welcome :-)

For sake of completeness, the solution was:

1. disable the Footnote plug-in

2. enable the footnote components in the Content Formatting plug-in manually.

Even if before this we had to do other actions and restart the server; probably this was not needed but we will never know...

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Jul 10, 2018 in Marketplace Apps

If you’re an Atlassian app developer, you’ll want to know about Atlas Camp!

This September 6-7, hundreds of Atlassian App developers will flock to Barcelona Spain to build skills, discover product roadmaps, meet face-to-face with the Atlassian team, and learn how to extend t...

182 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you