DVCS JIRA Setup not working

Morning,

I am trying to setup the DVCS connector in Jira 6.0.8 for the first time, and I am getting an error when I try to connect to our github enterprise version 11.10.302

Error!

Error obtaining access token. Response is invalid. Possibly bug in releases of GitHub Enterprise prior to 11.10.290.

We seem to have a version greater than what it is complaining about.

Side question for you: Url is set to http://server.domain.com/apps/jira, which is what users use to connect to Jira. Is callback url supposed to be different or the same? I set it as the same address.

5 answers

Hey David, this error seems related to the OAuth token to me. Have you tried to create a new Consumer in Github as in this page?

Cheers

I finally worked this out. The error occurred because when we go to http://github.domain.com, it automatically flips to https://github.domain.com. I needed to have my jvm point at a trusted store that knew about this certificate. The error just did not point at this at all unfortunately.

I added to setenv.sh: JVM_REQUIRED_ARGS=

-Djavax.net.ssl.trustStore=/local/mis/jira/home/truststore_file_here.jks

-Djavax.net.ssl.trustStorePassword=password_here"

hello , I met the same problem . I don't konw how to make /local/mis/jira/home/truststore_file_here.jks jks file .can you tell how to do ?

Hello,

 

The source of a truststore file generally comes from your networking group who have set up their own internal certificate authority (CA) so that they control what certs you should trust in things like your browser to identify whether a site is real or not.

 

However, if you cannot get it from them for some reason, then you can use the fact your browser is pretty good at seeing this information and generate your own truststore file.

 

I used for example a browser like IE to visit github site.  I then clicked on the little lock icon in the url line:

 

 

                       

 

It will show you the CA that is saying trust it by the way. 

 

Click on View Certificate

Click Details tab

Click Copy to File…

Click through wizard (you probably want to select Base-64 encoded X.509 (.CER))

Save to a file (e.g., mytruststore).  It would create mytruststore.cer file.  You need to find where it put it.  It put it on my desktop.

It should be a matter of then just doing something like the following (depends on location of your Jira and what you want the file to be called):

 

keytool –import –keystore /local/mis/jira/home/truststore_file_here.jks –file mytruststore.cer

 

 

(keytool is a java utility)

Hi . Thank you very much for your reply. I finally imported my self-signed certificate to jre trust store using openssl and keytool. Just like following. My JIRA is running on linux system.

 

sudo openssl s_client -connect <ip>:443 < /dev/null | sed -ne '/-BEGIN CERTIFICATE-/,/-END CERTIFICATE-/p' > <ip>.crt
sudo keytool -import -alias <ip>:443 -keystore /opt/atlassian/jira/jre/lib/security/cacerts -file <ip>.crt

 

By the way. In the JIRA "Add New Account" page, the "host URL" must be https://<ip> not http://<ip>. In your case it may be https://github.domain.com I think. This took me so much time to figure out it. Using http will be fail. 

Thanks again

I keep being asked for the keystore password.. how would I find that?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Jul 10, 2018 in Marketplace Apps

If you’re an Atlassian app developer, you’ll want to know about Atlas Camp!

This September 6-7, hundreds of Atlassian App developers will flock to Barcelona Spain to build skills, discover product roadmaps, meet face-to-face with the Atlassian team, and learn how to extend t...

137 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you