Constraint violation for package net.customware.confluence.plugin.scaffolding

Hi,

we have problem to start scaffolding plugin in our installation

2015-03-11 12:21:13,674 ERROR [localhost-startStop-1] 
[plugin.osgi.factory.OsgiPluginInstalledHelper] getRequiredPlugins 
Cannot determine required plugins, cannot resolve bundle 
'net.customware.confluence.plugin.scaffolding'
2015-03-11 
12:21:18,307 ERROR [localhost-startStop-1] 
[plugin.osgi.factory.OsgiPlugin] enableInternal Detected an error 
(BundleException) enabling the plugin 
'net.customware.confluence.plugin.scaffolding' : Constraint violation 
for package 'com.thoughtworks.xstream.converters.reflection' when 
resolving module 244.0 between existing import 0.com.thoughtworks.xstream.converters.reflection
 BLAMED ON [[244.0] package; 
(&(package=com.thoughtworks.xstream.converters.reflection)(version>=1.1.1)(!(version>=1.4.0)))]
 and uses constraint 146.0.com.thoughtworks.xstream.converters.reflection
 BLAMED ON [[244.0] package; 
(&(package=org.randombits.storage)(version>=5.2.4)(!(version>=5.3.0))),
 [248.0] package; 
(&(package=com.thoughtworks.xstream)(version>=1.1.1))].  This 
error usually occurs when your plugin imports a package from another 
bundle with a specific version constraint and either the bundle 
providing that package doesn't meet those version constraints, or there 
is no bundle available that provides the specified package. For more 
details on how to fix this, see https://developer.atlassian.com/x/mQAN
2015-03-11
 12:21:18,308 WARN [localhost-startStop-1] 
[atlassian.plugin.impl.AbstractPlugin] enable Unable to enable plugin 
'net.customware.confluence.plugin.scaffolding'
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: net.customware.confluence.plugin.scaffolding

We are not able to activate or register our license.

What is the problem?

Regards



2 answers

This widget could not be displayed.

Do you mind sharing which version of Confluence is the Scaffolding add-on being installed on and what other add-ons are enabled on that Confluence instance?

This widget could not be displayed.

I'm having the same issue on confluence 5.4.4 - all of the bobswift, servicerocket, and rb plugins installed.

Upgrading on a test system with 5.7.1 works fine.

 

1) Downgrading to RB storage servlet 5.2.4 from 5.3.0 (as noted in the error log below)

2) Uninstalling Scaffolding 5.4.0 & Scaffolding Metadata Plugin 6.2.1

3) Reinstalling scaffolding-plugin-5.1.5.obr

seems to be a temporary fix

 

 

Unable to resolve 257.0: missing requirement [257.0] package; (&(package=org.randombits.confluence.metadata)(version>=6.1.2)) [caused by: Unable to resolve 258.0: missing requirement [258.0] package; (&(package=org.randombits.storage)(version>=5.2.4)(!(version>=5.3.0)))].  This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see https://developer.atlassian.com/x/mQAN

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 22, 2018 in Marketplace Apps

How a Marketplace app tech team is achieving gender diversity

Hello! My name is Genevieve Blanch, and I'm the Marketing Manager at RefinedWiki, creators of apps to give teams the tools to customize Atlassian platforms. Currently, 44% of the tech team at Re...

464 views 3 17
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you