Compatibility with version 5.1.2 of JIRA

Hi,

I need to upgrade this week to JIRA 5.1.2, and the current version of the plugin is not compatible. Do you plan to release a compatbile version of the subversion plugin this week, or is there a way to make the actual version of the plugin to be compatible with the 5.1.2 version of JIRA ?

All the best,

Vivien TOURNEL

4 answers

The subversion plugin is still not completely compatible with Jira 5.1 since it generates the following error messages whenever the subversion tab is displayed. It caused by the subversion tab not supporting the sorting order feature as defined by 5.1. It was broken in the 5.0.7 release as well and I am not sure when it broken before that.

NOTE: username, ip-address and other values were manually modified.

2012-08-27 15:44:22,131 http-8082-6 ERROR username 936x1473x1 kozqez ip-address/browse/EA-137 [subversion.issuetabpanels.changes.SubversionRevisionsTabPanel] Unable to figure out how actions are sorted. I'm going to default to ascending

WebworkConfigurationNotFoundException{class=class webwork.config.XMLActionConfiguration, message='No such view mapping', name='com.atlassian.jira.web.action.issue.ViewIssue.actionInfo'}

The some data is displayed, so the plugin is usable, but the our logs are filling up with the above messages anytime a user displays an issue and looks at the subversion tab.

Hi Vivien,

I have just reviewed the Marketplace listing for the JIRA Subversion plugin and I can confirm that it is compatible with v5.1.2: https://marketplace.atlassian.com/plugins/com.atlassian.jira.plugin.ext.subversion

I believe the cause of this issue is that the compatibility is marked as compatible for JIRA 5.0 - 5.1 but this actually means that the plugin is compatible with all versions of Confluence v5..0.x and v5.1.x, and so it will install fine into your version of JIRA. Therefore you should be fine to just install the plugin and begin using it.

All the best,
John

I made a try, i download the version from the plugin website, but i get an error when i try to install it. Please see the attached document to see the error. Also I have a message telling me to update my upn. But when i click this link, nothing happen.

The error message in the log: 2012-08-13 14:53:20,178 pool-8-thread-2 ERROR vtournel 792x209x1 4shw4f 127.0.0.1 /rest/plugins/1.0/ [com.atlassian.upm.PluginInstaller] File 'atlassian-jira-subversion-plugin-0.10.11-distribution.zip' is not a valid plugin: File does not contain an atlassian-plugin.xml, obr.xml, or MANIFEST.MF file

I

I am also getting a failure on upgrade from 5.0.7 to 5.1.2 on my test system for the subversion plugin.

The UPM had some issues depending on what version you are upgrading from including that the upgrade link does not work. Try a manual upgrade to fix the UPM.

Manual upgrage fix the UPM issue, but even with an updated UPM, i still cannot instal the subversion plugin. Good news if you are reproducing the issue, this mean it's not due to my plateform.

I cannot read french, but are you trying to install the subversion using UPM? If so, that is not correct. You need to install the subversion plugin manually. Shutdown jira, The files in the zip file needs to be extracted and copied to their correct places and then restart Jira. Then check the logs.

https://studio.plugins.atlassian.com/wiki/display/SVN/Subversion+JIRA+plugin;jsessionid=6C8BE99EFB19541A83471E011CD8FF7F

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in Marketplace Apps

How to set up an incident workflow from the VP of Engineering at Sentry

Hey Atlassian community, I help lead engineering at Sentry, an open-source error-tracking and monitoring tool that integrates with Jira. We started using Jira Software Cloud internally last year, a...

1,336 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you