Class not found in SDK

Hello,

I'm using JIRA6.0.3 and I'm trying to rebuild a plugin I made to work on an older version (and it worked).

In atlassian-plugin-sdk-4.2.0 I have the class

com.atlassian.jira.issue.util.TextAnalyzer

and I succeed in packaging my jar file. But when I run it, on the server, in the directory

.../jira/atlassian-jira/WEB-INF/classes/com/atlassian/jira/issue/util/

there isn't the TextAnalyzer.class file (and some other classes differ)

Where am I wrong? Should I use some different version ?

Here are the early rows of the error I get when JIRA's starting

2013-07-04 10:11:52,890 ThreadPoolAsyncTaskExecutor::Thread 5 ERROR [plugin.osgi.factory.OsgiPlugin] Unable to start the plugin container for plugin
java.lang.NoClassDefFoundError: com/atlassian/jira/issue/util/TextAnalyzer
at java.lang.Class.getDeclaredConstructors0(Native Method)
at java.lang.Class.privateGetDeclaredConstructors(Class.java:2413)
at java.lang.Class.getConstructors(Class.java:1478)

2 answers

1 accepted

Plase provide your plugin pom.xml file. A possible problem would be wrong dependency to "atlassian-jira", but in 6.x you shoild depend on jira-api and jira-core

Yes Boris, you are right.
Adding dependencies from jira-api and jira-core all is ok now.

Thank you very much

Could you please mark my answer as correct.

Thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in Marketplace Apps

How to set up an incident workflow from the VP of Engineering at Sentry

Hey Atlassian community, I help lead engineering at Sentry, an open-source error-tracking and monitoring tool that integrates with Jira. We started using Jira Software Cloud internally last year, a...

1,396 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you