Checklist for Jira inline editing not working

I'm evaluating Checklist for JIRA currently and, even though I've set the edit checklist permission to allow Administrators to edit (and I'm an admin), I cannot edit the checklist items inline. Is it possible this is a limitation the trial license imposes?

2 answers

1 accepted

This widget could not be displayed.

It turns out the problem is with my expectation rather than with the tool. I had created a custom checklist field using this add-on in trial mode and my configuration of that field had the list items included as part of that configuration. Evidently, the tool is working as intended and does not allow for issue level inline editing of 'global' list items (those that are created as part of the configuration process). It DOES, however, allow for inline editing of checklist items created at the issue level. So, for my application, I modified the existing custom checklist field to have no pre-defined checklist items and created a text file containing my list markup which can then be copy/pasted into the import dialog at the issue level.

Personally, I view this as a workaround and would like to see 'global' checklist items be editable by those granted appropriate access.

Since this wasn't clear to me from the documentation provided online, I hope this is helpful for others taking a look at this add-on.

If you want to "Automate" your copy and pasting, you could create a workflow post-function and add a predefined list of items after the creation of the issue. All items inserted in the post-workflow functions are editable at the issue level. You can even delete them.

Thanks for the suggestion. I just tried that, but for some reason, after the issue is created, I'm not seeing the list I specified in the workflow post-function. I've tried placing the function before the initial issue creation step and after, and no luck. Any suggestions?

Did you publish your workflow? When you do changes to the workflow, it is saved as a draft. You need to publish it to see the effects. Happened to me a few times smile

Good question ... but, yes ... more than once now, even!

post-function.pnglist.png

Little bit puzzled ... are the other functions (e.g. Dev Team(s)) run after the transition? Also, any javascript errors? Any errors in the JIRA log file?

Finally, it seems to be a rather larged checklist. Can you try with only 1 item to see if it makes a difference?

I believe I've figured out the problem. My checklist field is configured with no options in the option list. When I change that to have at least one item in the checklist, then the post function fires correctly and appends the new options to the list. So it seems your code just isn't happy without at least one item in the configured list to begin with.

Hum ... I thought that I tried that combination when testing the feature. Will have to investigate that.

After further testing, I believe there are two problems. One is that only appending list items seems to be working in the workflow post-function. The other is that neither append or replace works if there are no options in the question configuration.

This widget could not be displayed.

Hi 

I saw this when I was reading about this plugin:

IE 9 and 10 issue

 

In certain cases following an inline edition, IE 9 and 10 will have difficulties with clicking on the the checkbox. If you have trouble clicking on the checkbox, try to click in the upper half of the checkbox.

Thanks for the information. I've realized the issue though and the problem is with my expectations rather than with the tool itself. See my next post for more.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Jul 25, 2018 in Marketplace Apps

Jira Cloud and Bitbucket Cloud Integration with Microsoft Teams

One of the newest products in the Microsoft family - Microsoft Teams,  is a chat-based hub for teamwork that integrates all the people, content, and tools your team needs to be more engaged and ...

718 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you