Can't supply license key to greenhopper

Hi

When I supply the eval license key to green hopper I get the message "The JIRA server could not be contacted. This may be a temporary glitch or the server may be down."

This occurs in Administration, Manage My Plugins.

I've got Jira 5.0.4

The universal plugin manager got updated to the latest (2.0.5)

Greenhopper is version 5.9.6

I'm running on Windows 7 64 bit with express install and internal database.

The issue I previously created in JIRA seems to be fine.

Any suggestions much appreciated.

Thanks

Martin

11 answers

Hi,

I have exactly the same problem, any solutions to this yet? It would be great to have it up running again asap.

Thanks,

Freddie

I've still got the problem. My eval is paused until this is fixed :-(

Hi Martin,

It's possible that the JIRA server's Base URL has not been properly set. If so, go to Administration -> General Configuration to set it. Make sure that you use the same URL when accessing JIRA from your browser.

Hi Arun,

The base URL is set to http://localhost:8080 This is what I'm using when I access JIRA on my laptop. Obvsiously that url won't resolve over DNS, just locally via my hosts file. It resolves to 127.0.0.1

Is there somewhere I can get some log information to help troubleshoot this?

Thanks

Martin

Thank you Norman, but all addresses and ports are included. Still no luck. Is it possible that this has something to do with that we are using the same user DB for both Jira and Confluence?

We are having the same issue. We just upgraded from 4.1.2 to 5.0.5. When I installed Green Hopper it said it found a vaild licence and successfully installed. Now it is using some old expired licence and when I try and update it with the current license from our account I get the error: "The JIRA server could not be contacted. This may be a temporary glitch or the server may be down."

I have checked the server and it can get to the Internet and to the plugins page. Any help would be appriciated.

Thanks!

Please check if you can reach the plugins.atlassian.com url from your Jira server. If you cannot not, talk to your network administrators.

The latest version of the UPM is at the 2.2 level for Jira 5.0.4 if you check the plugin site. I would try a manual install of the UPM since I had some issues with UPM not being able to update itself (bad link).

Hi,

Thanks for your response. Yes I can access that url from my jira server.

To be clear, I get the plugin to install, but when I paste in the license key, I get the error mentioned above.

Thanks

Martin

If I uninstall GreenHopper to try again, I get this message "The call to the JIRA server did not complete within the timeout period. We are unsure of the result of this operation." However it does seem to have uninstalled.

Starting again, I click Try GreenHopper. It installs successfully, asks if I want to get the license - I say Yes. It then says "Thanks for evaluating GreenHopper! Would you like to install your new GreenHopper license in your JIRA instance at null?

I guess this could be a clue to the problem.

Any ideas?

Thanks

Martin

Ok, Any news about this? It seems there is some issues with the Jira and pluginmanagement. I can install but not uninstall ANY plugins.

If your base url states localhost you need to change it to a DNS resolvable url. If you do not have one, then use the ipaddress of your computer. Use the "ipconfig" command at the command prompt to get your address information. I do not know type of ip network you are running (ipv4 or ipv6), but use the appropriate one for your network.

If you changed the default port then include the port address as well.

So it's not possible to have a installation of Jira that is not exposed on the internet ??

With no internet connection you will need to download your plugins yourself and install manually. It does not mean you cannot have a Jira installation.

Hi Norman,

Sorry, there may be some confusion here. I have an internet connection, and I have installed the plugin. The issue I have is that of supplying the license key to the installed plugin. I copy and paste the license key from atlassian, and at that point I get the error message "The JIRA server could not be contacted. This may be a temporary glitch or the server may be down"

Does that make sense?

Thanks

Martin

Well here's an interesting thing...

I've just tried to install the license key again, and it worked!

So what changed? Well I had looked at the brief install guide in the readme. I noted I didn't have a JAVA_HOME environment variable, so I set that.

I had been running the Atlassian JIRA windows service, so I stopped that, and ran start-jira.bat /fg instead. It told me I didn't have the JAVA_HOME variable defined correctly, saying it should point to a JDK, not a JRE - this contradicts the readme.

What I don't get is if JAVA_HOME is what's made it work, how come it managed to do *anything* before hand??

I've had a look back in the logs for when it didnt' work. Here's a snippet

10-May-2012 11:31:32 com.sun.jersey.server.impl.application.WebApplicationImpl onException
SEVERE: Internal server error
java.net.SocketTimeoutException

<stacktrace>

I'm intrigued by the path com.sun.jersey.server.impl.application.WebApplicationImpl as I live in Jersey. Is this a problem on a server in Jersey that's now been fixed???

Thanks again

Martin

Cannot tell without the full stacktrace, but it makes sense that either your connection path to the DNS or to the atlassian site was blocked by a down gateway site.

Do you have any error messages in the jira log files?

Hi,

It is time for our license to be updated for both JIRA and Greenhopper. I have tried updating the JIRA license and it was taken up by the system successfully. But when I tried to give the Greenhopper License it says that an "Invalid key was specified". Tried couple of times and unable to update the license.

Below are the JIRA and Greenhopper details:

JIRA: Version - 4.2.1

Green Hopper: Version - 5.4

Need assistance. Check the attachment for error message

Thanks!

I would contact support and have them work through your issue you. Given that your Jira license worked, the normal things that would cause this issue probably does not apply except a cut and paste error.

0 votes
Boris Berenberg Community Champion Jul 17, 2012

I don't know if this applies to the people commenting in this question, but I was working on a customer case where this was caused by a proxy they had in front of their JIRA instance. You can look into this on your instance by opening the browser to the page where you see the "The JIRA server could not be contacted. This may be a temporary glitch or the server may be down." issue. Then open the developer tools and go to the network tab. Then recreate the failure and look for a proxy authentication error.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in Marketplace Apps

How to set up an incident workflow from the VP of Engineering at Sentry

Hey Atlassian community, I help lead engineering at Sentry, an open-source error-tracking and monitoring tool that integrates with Jira. We started using Jira Software Cloud internally last year, a...

1,450 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you