Can not edit story from Story Map

I asked this a couple weeks ago but didn't have the tag set for Storymap.....

I'm trying out the Story Map plug-in on my test database and can not seem to edit the stories (or epics) from within the Story Map. I can open the story by clicking on the JIRA ID but can not edit the story using the pencil widget.

Any ideas?

4 answers

Hi Bob,

by clicking at the pencil, a layover should appear with an edit form. If it does not, please examine the following:

# did you get js errors?

# which browser do you use?

# is java script disabled at your browser?

# do you use a popup blocker?

cheers,

Florian

I'm getting an error (which was, for some reason, not visible before)

'You do not have permission to seee the specificed issue. Log in required'

I am able to open the issue using the Jira ID

hm hard to say from remote. But you obtain the error after clicking on the pencil, not on save or create epic/story, right?

# do you have permissions to move stories? Please try it again as admin of your test database

# 'Log in required' can be caused by a session time out

please give me some more infos to your configuration? jira/gh version, browser?

That's correct. clicking on the pencil. Opening the issue using the Story ID is fine and I'm able to edit without problems. One stange thing is that only sometimes do I get the error pop-up. Other times it just doesn't work (I have pop-ups enabled)

I have no problems moving stories. I don't currently have admin access to this DB but someone who does has now tried it with the same results (unable to edit via the pencil)

I've tried it with new sessions (i.e. restarted browser). I also have the same behavior on both Chrome and Firefox.

Here is my version info:

  • Agile project management for Kanban and Scrum software development powered by Atlassian GreenHopper (v6.2.3)
  • Bug tracking and project tracking for software development powered by Atlassian JIRA(v5.2.11#854-sha1:ef00d61)

hm, the error message is not a 'story map' message but it comes from jira itself. The story map plug in just calls a jira service to load specific issue data and obtains the message instead of the data.

Maybe we should ask your jira administrator if there is some particular configuration done at this instance; perhaps in the permission area? Maybe the permission configuration is related to a specific project - try to use another one.

We too cannot edit stories or epics from Story Map. However, for us, the whole tool seems to be in some kind of read-only mode.

All we see in each story/epic is: issue-type icon, key, summary, status icon, story points. Definitely no pencil icon.

(In case it matters, the Jira project has been around for at least 1.5 years.)

-Johnny

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in Marketplace Apps

How to set up an incident workflow from the VP of Engineering at Sentry

Hey Atlassian community, I help lead engineering at Sentry, an open-source error-tracking and monitoring tool that integrates with Jira. We started using Jira Software Cloud internally last year, a...

1,372 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you