Bulk update of checklist items not consistently working

I have this plugin in three different JIRA instances.  The bulk update of the checklist field is working fine in two of the three instances - 3.1.3 is the plugin version and JIRA is 7.0.10.  In the third instance, we have tried both 3.1.1 and 3.1.3.  

The problem is that when we go to bulk update the checklist field the first time we come to the page the css styling does not render the object correctly and it looks like you are typing in a text input field and not adding checklist items.  If you cause the page to fail going successfully to the next page in any way - like checking the "Change Component/s" and leave it empty then the page renders again but this time it renders correctly.  It has the field as Empty and every entry that you add is now added as a checklist item.  

Have you run into this or have a work around?  

150150150

1 answer

Hi Mark,

While developing Checklist V3, we did encounter that a lot. It is caused by JIRA not refreshing the customfield properly and not always (i.e. consistently) dispatching the events that we are looking for. We thought that we solved all of them. Are you using Checklist differently from one instance to the other? How do you access to the checklist: using shortcut, edit button, etc?

Finally, do you have service desk installed in the faulty instance?

Yves 

Your three questions - are we using checkilst differently from one instance to the other.  In this case, no.  We are using the bulk update feature of JIRA on each of the instances.  

 

How do we access the checklist.  Through the UI screen for the bulk update where the checklist field is one of the fields that can be edited in bulk.  

 

We do have service desk on all 3 instances in question.  It works with Service Desk 3.0.10 and Service Desk 3.1.6.  But it is failing on an instance that has Service Desk 3.0.10 too.  The problem instance has more plugins than most of our other JIRA instances.  However, that being said, this is working in our dev instance and we have all of those plugins on the dev instance too.  If you need me to go look at the full list and the versions of each, let me know.  There might be a difference there.  

Hi Mark,

I have tried to see if I could reproduce but to no avail. Can you take a look at the log file to see if any errors not seen in the other instances are present. Also, when you perform a bulk operation in the faulty instance, can you take a look at the browser console to see if any javascript errors/warnings are present? That could prevent JIRA from issuing the event Checklist requires.

Finally, did you try with different browser?

We are seeing javascript errors in Chrome (and Firefox) -   And if you check the checkbox for the checklist field PLUS have another field checked that has an error - the re-render has the first error go away.  So the error shows up if the checklist field is not checked when you load the page. 

 

Another version of skate is detected. Running SD skate in noConflict mode
BulkEditDetails.jspa:1148

Uncaught SyntaxError: missing ) after argument list
2

<code snippet - it is the first line in the if portion of the code>

       <script>
         if (!okapya.checklists.hasOwnProperty("o-checklist-11417")) {
           ==>  okapya.checklists["o-checklist-11417"] = okapya.createChecklist({"id" : "11417", "customfieldId": "customfield_11417", "canEdit": true, "parameters": {"strikeThrough":true,"showMoreCount":2,"discretionaryOptionIds":[],"emphasizeMandatory":false,"version":1,"reporterCanEdit":true,"showStatusMenu":false,"editRoleIds":[]}}, ${valueAsHtml});
         } else {
             okapya.checklists["o-checklist-11417"].registerData($valueAsHtml);
         }

</end code snippet>

batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:216

 

WARN: 'triggerPrivacyPolicySafeEvent' has been deprecated
batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:216

DEPRECATED - Dropdown constructor has been deprecated and will be removed in a future release. Use Dropdown2 instead.
at Object.exports.bindConfigDashboardDds (https://jira-eng-sjc1.cisco.com/jira/s/fc71895d8d2c5d8cf3cd99c8b2ae0ac5-CDN…_super/batch.js?atlassian.aui.raphael.disabled=true&locale=en-US:2899:1648)

 

For Firefox I saw the same thing happen but had 3 more warnings (that don't look like they mean anything):

  • Use of getPreventDefault() is deprecated.  Use defaultPrevented instead.
  • Use of Mutation Events is deprecated. Use MutationObserver instead.
  • Use of attributes' nodeValue attribute is deprecated. Use value instead.

Did this help?  Any feedback/response?  

Thanks,

Mark

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Marketplace Apps

Three tips for boosting your board's efficiency with Story Maps

Trello is one of the most effective tools for driving your sprints. It's customizable for every Agile team and product owners and Scrum masters (SM) love it. However, Agile teams often struggle with:...

818 views 2 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you