Bug on Dynamic Forms: Dynamic Select Field

Hello everybody,

I have detected a bug on the Dynamic Field Plugin. If I configure the dynamic select field and set the field mandatory, it's not possible in the mask to update the field.

The mask shows correctly that this field is required but if I want to select an entry from the select list, the required message doesn't appear and the process can't be saved.

Does anyone has a solution for that problem?

BR

Elke

2 answers

1 accepted

This widget could not be displayed.

Hello Elke,

It's happened because You have required flag on the field in Field Configurations. Dynamic Forms has build-in required feature so You need to remove this flag from scheme.

I hope this will help, Krzysztof

Hello,

thank you for the fast reply but I have checked your hint and that's not the reason.

In the field configuration the field is "NOT" required.

I explain my example,maybe there is a misunderstanding:

There is a dynamic selection field called: Risk for sideeffects

If the option "high" is selected of the field, the additional field : Checked by

should appear and this field should be mandatory. (only if the risk for sideeffects value is high).

The "Risk for sideeffects" field and the check "checked by" field are optional in the field configuration, but in the dynamic form configuration I said, that the checked by field should be required if the value "high" is set.

The problem: I choose "high" and the field appear and I choose a value from the selection but the message: Required fields

is still there, although I have select a valid entry.

I think it's a bug, or what's the mistake in my configuration?

Best Regards

Elke

Can send us a screenshot from create screen ?

plugins@intenso.com.pl

Regards, Krzysztof

yes sure! E-Mail is on the way.

Best Regards

Elke

Hi Krzysztof

 

Was this issue resolved with Elke several years ago? We now have exactly the same (or similar) bug appearing with the latest Dynamic Forms release. We have a field marked as required in Dynamic Forms configuration. When you edit an issue, this field is always reported as "The configuration cannot be completed. Some required fields are incomplete." even though the field does contain a value!

It only happens when you edit issue in the pop-up Edit screen. If you edit it in fullscreen mode, it works fine.

 

Any thoughts?

Thanks,

Andrey K

Hi Andrey,

we are checking this. We will inform you about the results.

Thank you.

 

Regards,

Piotr Patrzek

This widget could not be displayed.

Hi Elke,

Can You give us more details like plugin version, JIRA version ?

Regards, Krzysztof

Hello,

we use Jira Version 5.2 and Dynamic Forms Plugin Version:1.2.5

Best Regards

Elke

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 22, 2018 in Marketplace Apps

How a Marketplace app tech team is achieving gender diversity

Hello! My name is Genevieve Blanch, and I'm the Marketing Manager at RefinedWiki, creators of apps to give teams the tools to customize Atlassian platforms. Currently, 44% of the tech team at Re...

513 views 3 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you